Very Low Gaming Performance after Clean Installing The Windows.

Status
Not open for further replies.

alNzy

Commendable
Jun 24, 2016
3
0
1,510
0
Hello. My friend bought a new laptop. It's asus n550jk.

It has 6th generation intel core i7 processor.

16 GB RAM

Gtx 850m graphics card

It has also baterry issue. Baterry is always %0 and it doesnt charge. It was same before our clean windows installs too.

It's default os was windows 8.1 single language. But we did clean windows 10 install. After that, we downloaded the drivers on asus's official product page (n550jk) and we installed other drivers with iobit driver booster.

After that, my friend started csgo to test fps. It was +200 fps before formatting the laptop. But now its 20-100 fps and there ara lots of drops.

Then, we back to the windows 8.1 with clean install and we did the same steps. The fps problem was still there.

We uninstalled intel and nvidia drivers with "display driver uninstaller" and installed the stock drivers on asus's official product page, but it didnt helped.

After that, we removed the stock nvidia driver that we downloaded on asus product page and installed the lastest nvidia driver but it didnt helped too.


What we have tried:
Clean install lastest graphics card drivers
Clean install stock graphic card drivers
Set default graphics card as nvidia
"Prefer maximum performance" on nvidia control panel's power management setting.
Disable baterry save option on nvidia experience
Use high performance system profile
Game Booster
Reinstall csgo and steam.
Update DirectX
Tried to restore factory settings via 20gb restore partition. But we cant access partition and windows doesnt accept the 20gb restore partition as default recovery partition.



Also we tried on other games too. Their fps is not bad a lot, nearly same. But they have drops too, but not much as csgo.



I trust you guys. Please help :(



Also sorry for my english but i think its enough to understand. I can understand everything you write, but its hard to write something on English. So please write if you know anything about that can solve this issue.
 
Status
Not open for further replies.
Thread starter Similar threads Forum Replies Date
M Laptop Tech Support 0
kittychloe Laptop Tech Support 1
K Laptop Tech Support 3
TommyInfinity Laptop Tech Support 10
B Laptop Tech Support 3
B Laptop Tech Support 1
M Laptop Tech Support 2
P Laptop Tech Support 7
K Laptop Tech Support 2
S Laptop Tech Support 5
T Laptop Tech Support 4
N Laptop Tech Support 5
P Laptop Tech Support 2
S Laptop Tech Support 3
L Laptop Tech Support 4
B Laptop Tech Support 1
P Laptop Tech Support 1
P Laptop Tech Support 2
S Laptop Tech Support 3
R Laptop Tech Support 4

ASK THE COMMUNITY