Any way to fix Bluetooth audio wireless delay for Windows 10?

Status
Not open for further replies.

xtobymc

Honorable
Jan 5, 2013
5
0
10,520
1
I got a new pair of wireless earbuds for Christmas today, not cheap ones either, and I had hoped to use them for many different purposes whether it's my desktop PC or my phone when I'm in the gym.

Unfortunately I have discovered that Bluetooth has a rather noticeable audio delay, to the point where things like gaming in particular are basically unplayable. If, for example, I shoot a gun in a game, I hear the audio about 0.3 seconds after I shoot the gun, it's incredibly annoying. YouTube videos seem relatively okay (watchable but not ideal), and there is less lag on my S7 Edge phone than on Windows 10.

Is there any way to fix this in Windows 10? I understand wireless signals will always have greater latency but surely Bluetooth isn't restricted to delays of this significance in 2017? If it's any help I'm using Jaybird X3's with a Bluetooth 4.0 USB dongle I purchased on Amazon.

 

bigpinkdragon286

Honorable
Oct 3, 2012
229
0
10,910
46
Make sure you're using the A2DP audio profile for your earbuds. That is the profile that is used for a proper, high quality, stereo link over Bluetooth. If using a microphone on the same device, the A2DP profile will be disabled.

Could also be the wireless link itself having to start and stop with the audio. Bluetooth does not necessarily start a continuous stream, but instead starts and stops the audio stream as necessary to conserve energy.

You might try, after pairing your Bluetooth earbuds and connecting them, run the small SPDIF KeepAlive utility to keep the connection from turning off. Your battery life on the earbuds will likely decrease by a little bit, but the audio stream won't be stopping and restarting. This is worth a try to see if it improves audio sync. The utility needs to be run after the earbuds are connected and in use, or they won't appear to SPDIF KeepAlive as a sound device to keep on.
 

Cheap_Red_LED_Fan

Prominent
Jun 6, 2017
5
0
510
0
Its most likely the dongle. USB dongles normally have a greater delay than a dedicated card. I would suggest upgrading your wireless card to one with Bluetooth.
 

bigpinkdragon286

Honorable
Oct 3, 2012
229
0
10,910
46
Make sure you're using the A2DP audio profile for your earbuds. That is the profile that is used for a proper, high quality, stereo link over Bluetooth. If using a microphone on the same device, the A2DP profile will be disabled.

Could also be the wireless link itself having to start and stop with the audio. Bluetooth does not necessarily start a continuous stream, but instead starts and stops the audio stream as necessary to conserve energy.

You might try, after pairing your Bluetooth earbuds and connecting them, run the small SPDIF KeepAlive utility to keep the connection from turning off. Your battery life on the earbuds will likely decrease by a little bit, but the audio stream won't be stopping and restarting. This is worth a try to see if it improves audio sync. The utility needs to be run after the earbuds are connected and in use, or they won't appear to SPDIF KeepAlive as a sound device to keep on.
 
Apr 4, 2018
1
0
10
0
Even this is a bit older google search makes it quiet prominent so i have to say a few thigns here.


First no you cannot get rid of audio lag. THis is one of the Major issues with standard A2DP. So Other posters saying make shure using that - well not so much.

The only Way to have Bluetooth without audio delay is using the APTX Bluetooth Protokoll.
Win10 finally supports it native if your hardware supports it. So you BT Dongle must support it and your Headphones, earbuds or speakers must support that too.

There is defently no other Way to solve this, nothign absolutly nothing you can do about it otherwise.
But luckily AptX finally has its breaktrough so currently most better and premium BT Audio Products ship with it, Android O is support it native too.

Even apple supports it on the macbooks...
 

bigpinkdragon286

Honorable
Oct 3, 2012
229
0
10,910
46
aptX is a fine technology but can't help the original poster in this situation as his Bluetooth headset doesn't support the codec.

You really should differentiate between the three aptX codecs available, as each has it's own latency range. Only aptX LL (Low Latency) supports a latency that is under 40 ms, and fewer devices support this codec than the normal aptX codec.

Standard aptX has latency that ranges all the way up to what A2DP (SBC codec) supports, so isn't a significant improvement in that regard. It's better, but not by so much that if A2DP isn't meeting one's needs, aptX is going to magically fix it.
 
Sep 7, 2018
1
0
10
0
I was searching for the solution to the same thing and this post got me thinking about the windows audio processing that was turned on for me. May not be true for all people, but I when i went to playback devices and properties of my headphones, then spatial sound, I found that Windows Sonic for headphones was turned on. When i turned it off, it seemed to improve the delay issue by a considerable amount, but it didn't fix it completely. I use beats studio wireless 2 and some 7$ USB bluetooth adapter i got from amazon that had great reviews. Again don't know if it would work for everybody just thought i should post it in case.

Probably aren't looking for an answer anymore, but I thought could be helpful to others.
 
Status
Not open for further replies.
Thread starter Similar threads Forum Replies Date
R Audio 2
L Audio 2
K Audio 1
Sonic Illusions Audio 3
T Audio 3
iHacki44 Audio 2
C Audio 5
J Audio 2
D Audio 6
C Audio 1
M Audio 3
S Audio 2
V Audio 6
A Audio 4
2 Audio 2
N Audio 2
P Audio 10
3 Audio 2
M Audio 1
J Audio 2

ASK THE COMMUNITY