asus eeebook x205ta

dhaynes221

Honorable
Jan 11, 2014
5
0
10,510
0
II am on holiday and brought a WD My passport ultra 0820 external drive and a 128 g. lexar memory stick and sandisk 16 g memory stick with backup data on them that I need to use. The Asus eebook now won't let me open them. It sees the drives, but there is a yellow explanation mark through them and it says no drivers are installed. I tried purchasing a driver update program but it didn't do anything. Also tried going on WD site, but also got no where. Would it help to install Window 10? I am a bit desperate .
 

SuperSoph_WD

Estimable
Jul 30, 2014
168
0
4,910
83


This sounds pretty frustrating, indeed! You should definitely try clean installing Windows 10 and see if that will resolve your issue. Otherwise, you most definitely need to get in touch with the laptop manufacturer's customer support for assistance. If there's anything wrong with your notebook, you should be able to RMA it and get it replaced (if it's still within the warranty period). You should backup all important data from the laptop beforehand, though.

To make sure there is nothing wrong with the WD My passport and the memory sticks, I'd recommend you attempt to plug them to another computer and see how they will get recognized there.

Hope it helps. Best of luck!
SuperSoph_WD

 

SuperSoph_WD

Estimable
Jul 30, 2014
168
0
4,910
83
Hey there, dhaynes221!

It looks like a USB Hub controller driver issue that should be easily resolved once you re-install your drivers. I'd recommend you do that manually from the laptop manufacturer's official website. You should be able to find your Eeebook there with all the available drivers and utilities needed for the hardware to work. Select your current OS version and make sure you update all the USB drivers.

Hope this helps.
Keep us posted! :)
SuperSoph_WD
 

dhaynes221

Honorable
Jan 11, 2014
5
0
10,510
0
Thanks. The devices were all working on other computers before I left to load the files. Not sure if I checked them on the the Asus before I left, probably not, but they have worked in the past. Asus is running Windows 8.1 with shell programs to emulate WIndows 7
 

dhaynes221

Honorable
Jan 11, 2014
5
0
10,510
0
I have tried downloading the driver from WD's website, but they only have a driver utility program which says that my drivers are all up to date! I would have used System Restore, but this is one of those dinky little laptops with no hard drive, so system restore was turned off. Arrrgggh! Stuck again (still). The only disadvantage of these cheap little laptops which otherwise are great. A tiny hard drive is a problem though.
 

SuperSoph_WD

Estimable
Jul 30, 2014
168
0
4,910
83
Hey there again, dhaynes221!

I'm sorry to see you struggle with this! :( You shouldn't have such issues if everything is running smoothly. I'd suggest you uninstall & reinstall the WD My Passport as a device from Device Manager as well.
I also recommended you to go to the Laptop manufacturer's website, rather than our official website. The laptop's website is where you should be able to find and reinstall manually all the USB hub controller drivers that are specific for your laptop's model and compatible with your OS version!

Give these steps a try as well and keep us posted! :)
SuperSoph_WD
 

dhaynes221

Honorable
Jan 11, 2014
5
0
10,510
0
Thanks everyone. I think maybe I am really hooped on this one. Went to Asus' site and tried to download drivers. There is nothing listed for USB or peripherals, so I tried their backup (refresh} program which I was able to run after I run the compress program on the drive to free up some space. It said there was a problem and didn't make any changes. When I went to WD's site - same thing. Couldn't find any USB or peripheral driver downloads. When I ran their program to identify the My Passport drive, it couldn't find it, even though it shows on the laptop. I also tried removing the drive and resinstalling but the drive was not found. I have tried this before and all that happened was that the drive came up again with the "no driver" problem when I rebooted. I haven't tried to download drivers for the memory sticks yet, but suspect the same problems. I may try Windows 10 as a last resort, but not sure if I have enough room on the drive to install! Very frustrating.
 

SuperSoph_WD

Estimable
Jul 30, 2014
168
0
4,910
83


This sounds pretty frustrating, indeed! You should definitely try clean installing Windows 10 and see if that will resolve your issue. Otherwise, you most definitely need to get in touch with the laptop manufacturer's customer support for assistance. If there's anything wrong with your notebook, you should be able to RMA it and get it replaced (if it's still within the warranty period). You should backup all important data from the laptop beforehand, though.

To make sure there is nothing wrong with the WD My passport and the memory sticks, I'd recommend you attempt to plug them to another computer and see how they will get recognized there.

Hope it helps. Best of luck!
SuperSoph_WD

 
Thread starter Similar threads Forum Replies Date
Schize Laptop Tech Support 1
M Laptop Tech Support 1
H Laptop Tech Support 1
A Laptop Tech Support 3
N Laptop Tech Support 1
M Laptop Tech Support 2
H Laptop Tech Support 1
M Laptop Tech Support 6
J Laptop Tech Support 2
Y Laptop Tech Support 3
C Laptop Tech Support 1
M Laptop Tech Support 2
Kitanul Laptop Tech Support 8
K Laptop Tech Support 1
F Laptop Tech Support 1
K Laptop Tech Support 1
H Laptop Tech Support 1
V Laptop Tech Support 2
R Laptop Tech Support 1
L Laptop Tech Support 2

ASK THE COMMUNITY