ASUS ROG G750JM possible short-circuit in motherboard. Help and guidance required.

gamerabei

Prominent
Sep 22, 2017
2
0
510
0
Hi guys!
I was cleaning my laptop fans and dusting the insides.
I distinctly remember disconnecting the charger(it doesn't have a battery attached) and then going about my business but, then when I reinserted the charger and switched on the power button, it didn't turn on.
I can't see how it could have shorted. But, still, assuming it did short out in some weird way, can someone help me identify what exactly the problem could be and how to fix it, or even if it is worth fixing or not?
Also, I am adding two pictures of the motherboard, both depicting an IC, highlighted with red and blue colour(they are one and the same IC not two separate ones) which gets really-really hot as soon as I plug the charger in, without even pressing the on button.
Thanks.

*Link to the images of the motherboard*
https://imgur.com/a/CNw43
 

zer0c007

Notable
Jun 10, 2017
108
1
910
52
From what I know if a usually most tech savvy people will test power adapter and check the cords from the power adapter input jack pin inside the laptop to the motherboard is not problematic. If its problematic they through the trouble of sodder/soldering the appropriate cords however if the things go wonky elsewhere they replace the laptop motherboard as it will to hard to diagnose.

Try removing the cmos battery if its not soldered to the board and press and hold power button to discharge the laptop, this may be actually a useless suggestion but I really do not have any other advice to offer.
 

gamerabei

Prominent
Sep 22, 2017
2
0
510
0


Thanks a lot for replying, but, no that's not the problem.
You missed one point above that says one of the ICs gets boiling hot.
I can confirm there is nothing wrong with the charger or something along the lines.
The board is getting power, I checked that with a multi-meter, but, there is something wrong somewhere that is causing the problem.
Thanks anyways.
Anyone else?
 

turblaxtv

Prominent
Jan 31, 2018
1
0
510
0

Hello, I am having the exact same issue the board gets power and can charge the battery but it will not turn on. The keyboard doesnt light up or the power button I dunno what's the issue I am using a multimeter but dont know where to check. Have you found out the issue???
 
Thread starter Similar threads Forum Replies Date
D Laptop Tech Support 4
dipudangol Laptop Tech Support 8
M Laptop Tech Support 1
R Laptop Tech Support 1
C Laptop Tech Support 2
R Laptop Tech Support 2
S Laptop Tech Support 1
B Laptop Tech Support 7
C Laptop Tech Support 5
C Laptop Tech Support 4
L Laptop Tech Support 5
Trun187 Laptop Tech Support 2
S Laptop Tech Support 4
S Laptop Tech Support 8
S Laptop Tech Support 11
E Laptop Tech Support 3
Z Laptop Tech Support 1
vindictivegnome Laptop Tech Support 6
D Laptop Tech Support 1
K Laptop Tech Support 1

ASK THE COMMUNITY