ASUS X553M won't turn on, weird problems

MADAO92

Commendable
Jul 24, 2016
1
0
1,510
0
My almost 2 year old ASUS lap-top X553M won't turn on for 2 reasons

It started a year ago when the screen randomly wouldn't turn on, mostly after restart or sleep. I could hear the cracking sound so I connected to an external monitor it would work normally about half the time. Another problem that would occur is described in the next section

It's still under guarantee so I took it for asus service and they changed the motherboard. Then it worked normally for couple of months. Then it went bonkers again. Took it to service again and they changed the screen and the connecting cable. It worked for few months

Now it's the another problem, again. When I turn the laptop sometimes (on about 1/4 of startups) only the led lamp turns on and stays on, however the laptop makes sound as when it shuts down and nothing happens, just a very faint continous beep sound can be heard. I need to press and hold shutdown and repeat it couple of times before the laptop starts normally. This happened before and it deteriorates with time (It happens more often and I need to restart multiple times).

Since asus service was of no help, does anyone knows what or where might be the problem. My guess would be some power failure, however how can I fix that?
 
It doesn't sound like a power failure, at least not to me. It sounds like a BIOS error. That is something you can look into pretty easily by going into the BIOS on start up and see if anything isn't listed correctly. Sometimes when tweaked by someone (like the repair people you went to) they can make things worse instead of better.

Also, you might try starting it up in "Safe Mode" and see if you continue to get the problem. If it doesn't happen, then there is something (software wise) going on that is the cause.

I have to say though, if the thing is still under a warranty, and you have brought it back to them many times, then it is about time they just replaced it for you.
 
It doesn't sound like a power failure, at least not to me. It sounds like a BIOS error. That is something you can look into pretty easily by going into the BIOS on start up and see if anything isn't listed correctly. Sometimes when tweaked by someone (like the repair people you went to) they can make things worse instead of better.

Also, you might try starting it up in "Safe Mode" and see if you continue to get the problem. If it doesn't happen, then there is something (software wise) going on that is the cause.

I have to say though, if the thing is still under a warranty, and you have brought it back to them many times, then it is about time they just replaced it for you.
 
Thread starter Similar threads Forum Replies Date
H Laptop Tech Support 1
S Laptop Tech Support 2
R Laptop Tech Support 1
R Laptop Tech Support 5
A Laptop Tech Support 5
M Laptop Tech Support 1
A Laptop Tech Support 4
M Laptop Tech Support 1
A Laptop Tech Support 1
R Laptop Tech Support 1
A Laptop Tech Support 1
C Laptop Tech Support 1
A Laptop Tech Support 2
N Laptop Tech Support 1
D Laptop Tech Support 1
D Laptop Tech Support 1
D Laptop Tech Support 1
A Laptop Tech Support 1
F Laptop Tech Support 1
P Laptop Tech Support 3

ASK THE COMMUNITY