Broken Sound with Turtle Beach PX22

Force_Pixel

Estimable
May 11, 2014
3
0
4,510
0
Hey guys I honestly don't know how to explain this in FULL depth. But I'll do what I can. I'm currently using the "Turtle Beach Earforce PX22 Universal headset" for my PC. On which I game a lot. But the problem with the headphones is that it doesn't play continuous sound. For example let's say I were playing Skyrim. If the volume got quiet below a certain point. My headphones just won't play it through. And that's what I don't like. I play games where sound is key, like the DayZ mod. I need to know where and what direction people shoot from, and unless my headset pics everything up, I really can't. So if anyone knows how to fix this, or at least what the problem is, please let me know!

Thanks,
Tyler.
 

Madman9996

Estimable
May 17, 2014
10
0
4,570
2
That sounds like something is not plugged in properly try unplugging everything and making shure there is nothing in them then plug it all back in.
 

Force_Pixel

Estimable
May 11, 2014
3
0
4,510
0


I actually had tried this. There was nothing in the USB. Or in the USB slot. The extension has a headphone jack as well as the USB plug-in, although Plugging in the headphone jack doesn't make a difference to the sound, so I'm not quite sure what to think. (I apologize if this sounds weird, i am half computer illiterate)
 

Force_Pixel

Estimable
May 11, 2014
3
0
4,510
0


Alright, I gave that a go. And it all looks good. No kinks anywhere. And That sucks man, happened to me once.
 

Virus0420

Estimable
Aug 9, 2014
1
0
4,510
0
ok i fixed the issue....unplug headphones from amp then begin to plug it back in while playing something with sound so you can hear the fix ,you have to barely plug it back in to the amp,plug it in but not fully fixed mine perfect...mess with it just make sure you are listening to a song or something so you can hear the fix.....WORSE CASE WORSE just go to the store where you bought your headphones buy the exact same pair go home put the broken ones back in the box and return it and say it wasnt compatible with your system....Have done this multiple times with razor hearphones at bestbuy and walmart there is no serial number on headphones very easy fix....but in this case try the method i described above seems to work with my px22s and i was having the same issue as all of you......Thanks and Peace
 

Eric_39

Estimable
Dec 26, 2015
1
0
4,510
0
The problem is that it's playing sound as if it is the communication device. You can test this by turning down the middle wheel. If no sound comes out with that turned down that is your issue.
 

Richard_68

Estimable
Dec 31, 2015
1
0
4,510
0
i have a crackling sound on certain low frequencies. Can't quite put my finger on the problem's source. Also the amp doesn't work well. It only had all the faders working properly once (equalizer and separate volumes for video game\windows).. I'm very disappointed with these headphones.
 

Richard_78

Estimable
Jan 5, 2016
1
0
4,510
0
Im having this same issue ive tried all of the above and my sound is still disconnecting and reconnecting at random for a few seconds my drivers are good the cables are good the ports are good and the headphones are brand new havnt even used them for a week and they started doing it right out of the box.
 

LandonSlayz

Commendable
Feb 9, 2016
1
0
1,510
0
I have this same headset and I had the same problem. It's not a hardware issue, its your OS selecting the wrong output. At the bottom right of your screen at the desktop you will see a Speaker, right click on that and click playback devices. You should see a box with a list of playback devices. Click the one called "Speakers" and make sure it's not the one that says "Turtle Beach PX22". Click OK then apply, it should now be fixed.
 

punkZappa

Commendable
Mar 24, 2016
1
0
1,510
0
i just fixed mine a minute ago... just make sure to follow the instruction of how to connect your headphone on below link...
px22 setup link: https://support.turtlebeach.com/entry/830517544/

the thing is need to plugin also the 3.5mm stereo jack on the headphone socket of your PC together with the USB connector..

Right-click either the Speakers or Headphone output (name varies, but it's typically labeled "Realtek High Definition Audio") and choose "Set as Default Device". Mine works choosing the Speakers with "High Definition Audio Device" label.

but you can try all the playback devices and check which works fine to your headphone... use below you tube link to check at around 45 - 50 secs in the video the sounds disappearing for a while on px22 so you can check which playback devices works for you... you will know if your headphone is fixed if the sound is continuous in that video... hope it helps....

Broken sound test link: https://www.youtube.com/watch?v=Sa69-Grz3d8
 

CCG_CherryBomb

Commendable
Sep 11, 2016
2
0
1,510
0


Here's what fixed my PX22 headset:
Go into "Sound" under "Control Panel". Once there, under the "Playback" tab, make sure your PX22s are set as the default device.
 

Waylon_1

Commendable
Nov 25, 2016
1
0
1,510
0
Also if this is for a PC, make sure you have the right option selected on the box. The options are "PC/Mac - PS3 - XBOX". By default it's on PS3, which gave me the issue posted above
 

yaboidaniel

Prominent
Feb 1, 2018
1
0
510
0
If your audio is completely silent in quiet moments of a film or game, then the best thing is to in windows 10 is:
menu button -> Settings -> sound configurations -> enhancements -> turn loudness equalisation on.

This will only decrease severity of the problem no the problem itself
 

Similar threads


TRENDING THREADS