Canon G7 and windows vista

Aphrodite6285

Distinguished
Mar 24, 2010
3
0
18,510
0
I want to purchase a Canon G7 but the literature indicates that it is not compatible with Vista. Is there a solution to this problem?
Thank you
 
G

Guest

Guest
Some of the software which would be supplied with the camera may not work with Vista -- but the camera should connect and allow you to transfer pictures to the computer regardless of the operating system.

I would go to local Canon website use the e-mail address there to request that they confirm that connectivity will be okay.
 
G

Guest

Guest
Some of the software which would be supplied with the camera may not work with Vista -- but the camera should connect and allow you to transfer pictures to the computer regardless of the operating system.

I would go to local Canon website use the e-mail address there to request that they confirm that connectivity will be okay.
 

Aphrodite6285

Distinguished
Mar 24, 2010
3
0
18,510
0
Thank you so much!! Here's the answer I found at Canon's site:
Windows Vista requires ZoomBrowser version 5.8 and later to install. If you camera shipped with a solutions disc that has an earlier version of the software than ZoomBrowser 5.8 please click the download link for up to date software options
 

ASK THE COMMUNITY