Cant update my ATI mobility Radeon HD 5470.... Stuck in 13-4 update

TheSleeperHit

Estimable
May 4, 2014
6
0
4,510
0
I am trying to update my video driver.... after clean uninstalling the previous driver... I manually downloaded "14-4-mobility-win7-win8-win8.1-64-dd-ccc-whql" for Mobility HD which is the latest driver update for my device, but the package wont install and just skip installing the graphic driver part of the package... I even tried overwriting an older driver to no avail... I am stuck at 13-4 update... which is the only update that will install the graphic driver... What gives?
 

TheSleeperHit

Estimable
May 4, 2014
6
0
4,510
0


Ahhh.... I tried your solution.... but nothing happened.... the new driver still would skip installation... I even tried installing the super old base driver when I bought my laptop... but when I tried installing the newest driver... It said that my driver is up to date!?! What the heck....
 

TheSleeperHit

Estimable
May 4, 2014
6
0
4,510
0
Auto detect and install detects my gfx correctly after sweeping, but the problem still remains... When I install the downloaded driver from "auto detect and install" it skips installing the gpu driver completely... ( I have no driver installed at this point).. It doesnt even say installation failed... Just skips it... It install the other content inside the driver package like hdmi something something but not the gfx driver...... :(
 

TheSleeperHit

Estimable
May 4, 2014
6
0
4,510
0
When nothing is installed it says standard vga adapter... but when I install a driver... It says ATI mobility radeon HD 5400 series.... Beside the 13-4 update... anything after that wont install the gfx.... I tried overwriting a 13-4 update with 14-4 update but when I check it in the "manual install" 14-4 says that my driver is latest... I uninstalled 13-4 update and installed the OLDEST driver I can find for my gfx and I tried to overwrite that driver with 14-4,it still says my driver is the latest update....
 

clutchc

Distinguished
Apr 22, 2009
418
1
19,215
93
If it says "ATI mobility radeon HD 5400 series" for the driver, then you have it installed. But you should be able to adjust the display for your monitor's resolution. Is that working? What resolution is your monitor?
What does the CCC (Catalyst Control Center) report under Information/Software?
 

TheSleeperHit

Estimable
May 4, 2014
6
0
4,510
0


Ooh... I misunderstood your question... It only says Mobility radeon HD 5400 when I install 13-4 update... It still says standard vga adapter after installing 14-4 update.... it wont even install the CCC content of 14-4 package.. :(
 

clutchc

Distinguished
Apr 22, 2009
418
1
19,215
93
I'm out of ideas. I've never known that to happen. Ever. If you are sure you are downloading the correct driver pkg for your Chip and OS version, I'd contact AMD and ask them for an explanation.

However, with an on-board gfx chip, there really isn't any benefit to moving from 13-x to 14-x. All the changes/improvements/bug fixes (if any) are designed around the discrete cards. If you end up having to stay with 13-4, you won't be losing a thing.

But I'm still stumped. You could try uninstalling the driver again, this time with AMD's Clean Uninstall Utility. But you may also lose your AMD chipset/SATA drivers too. However, Win7 will re-install them at boot from its database of drivers, and you can update them online afterwards if you want. But you may not want to go that far.
http://support.amd.com/en-us/kb-articles/Pages/AMD-Clean-Uninstall-Utility.aspx
 

TheSleeperHit

Estimable
May 4, 2014
6
0
4,510
0


Hmm... I am a bit confused... I am pretty sure my gfx is a discrete card... Well, actually my gfx just got revived by reflowing cause it died because of me OCing it... (This taught me a lesson not to OC a laptop ever again) I just dont know if this information matter to my problem... I really dont have a problem updating my driver prior to 13-4...
 

full0fjoy

Honorable
Feb 7, 2014
1
0
10,510
0
I had the same problem with "14-4-mobility-win7-win8-win8.1-64-dd-ccc-whql.exe". It doesn't update my previously installed driver. Also doesn't install fresh one after uninstalling the previous driver completely (tried driver sweeper-cccleaner-restart approach). I have ATI Mobility Radeon HD 5400 Series, with Win8.1 x64.

During fresh custom installing, previous driver (13-12_mobility_win7_win8_64_dd_ccc_whql) gives option to install the driver but the current one doesn't.

My Solution:
Install AMD Catalyst 14.7 RC Driver (beta version)
http://support.amd.com/en-us/kb-articles/Pages/latest-catalyst-windows-beta.aspx
It works fine for me. I did a fresh install (removed previous driver with Driver sweeper, used CCCleaner and did a reboot)

Another possible soln: Check for windows updates. There is one update from AMD for the latest display driver.

Hope this helps. :)
 
Thread starter Similar threads Forum Replies Date
D Laptop Tech Support 1
E Laptop Tech Support 0
Zig_ZagDust1995 Laptop Tech Support 1
K Laptop Tech Support 2
badwwolfe Laptop Tech Support 0
Navneet Gautam Laptop Tech Support 11
S Laptop Tech Support 4
D Laptop Tech Support 0
SSorin Laptop Tech Support 0
I Laptop Tech Support 0
M Laptop Tech Support 0
aemerte Laptop Tech Support 0
X Laptop Tech Support 0
M Laptop Tech Support 0
D Laptop Tech Support 1
R Laptop Tech Support 2
TheQuickCook Laptop Tech Support 8
Z Laptop Tech Support 16
Terry Holland Laptop Tech Support 2
L Laptop Tech Support 1

ASK THE COMMUNITY