Solved! Dell Inspiron 5567 no display, but everything else works...

p_t

Jan 10, 2019
7
0
10
Best answers
0
Hi all,

This laptop was dropped and the LCD shows physical damage. Upon booting I even get the 2/7 blink code, which correlates to an LDC failure. I've been using an external monitor for over a year or more, and it's just become a stationary laptop.

I'm now trying to fix this problem, so I ordered a new display assembly. It seemingly arrived DOA, as I got the same exact results as with my own. So I ordered another one... Same thing. So then I ordered the precise LCD screen that shipped with my original laptop, and not a difference it made.

I find it interesting that the only thing affected is the display. It's an FHD LCD, and the touch screen works, there's just no display. There's no other issues with the laptop.

So all in all I've tried 3 different display assemblies, and at least 2 confirmed working, although I assume all 3 to be working. This includes 3 separate LCD's and 3 cables.
 

webworkings

Titan
Apr 6, 2016
23,602
96
107,040
Best answers
12,038
That is the integrated graphics. There is also a another. The following is from the specifications for that device... found in the link I included before.

AMD Radeon R7 M445 4GB dedicated video card
Intel HD 620 integrated graphics

So, it sounds like you may well have a problem with the AMD Radeon. Which could mean it is damaged or fried. I would suggest having a tech look at it.


 

webworkings

Titan
Apr 6, 2016
23,602
96
107,040
Best answers
12,038
The display that is attached (well all of them) and the external monitor, are they running on the same graphics? or not? It is possible that one is using integrated and the other isn't. Which would alter your results.
 

p_t

Jan 10, 2019
7
0
10
Best answers
0
Thanks for your reply.

I only have the Intel HD Graphics 620 installed, and the driver was updated today.

Edit: At least when I go into Device Manager>Display adapters, it's the only one listed.
 

p_t

Jan 10, 2019
7
0
10
Best answers
0
I completed a diagnostics test. When attempting the diagnostics test I had one of the newly ordered display assemblies connected. I used the flashlight on my phone and attempted to shine it on the screen, but I couldn't make out anything.



The test provided me with the following errors.

- Fail PSA V4304. 12 Error 2000:0415. Validate Code : 94363 Cables - Check the following cable, jumper, connection or sensor: LCD Cable;

- Fail PSA V4304. 12 Error 2000:0142. Validate Code : 87304 Hard Drive 0 - S/N 86STTUGTT, Short self test unsuccessful.
 

p_t

Jan 10, 2019
7
0
10
Best answers
0
Could this possible be a BIOS issue? I know that the LCD cables are good, because this assembly in particular was double checked for quality before it was shipped.
 

webworkings

Titan
Apr 6, 2016
23,602
96
107,040
Best answers
12,038
Perhaps, but I would still look at a GPU issue. This list of specs, if you go down about 1/3 of the way down the page, you will see the specs. It shows there should be a video card.... https://laptoping.com/specs/product/dell-inspiron-15-5000-5567-i5567-15-6-laptop-7th-gen-intel-core-optional-touch/
 

p_t

Jan 10, 2019
7
0
10
Best answers
0


Is it the Intel HD Graphics 620? I know I have that. Is that not the graphics card?
 

p_t

Jan 10, 2019
7
0
10
Best answers
0
I'm almost positive I don't have the AMD Radeon. I think there was a model that shipped with just the integrated Intel graphics, and that's what I have.

Let's assume I'm correct, what should my next step be? Also if you'd like, I can verify this for you somehow on my machine.

Thanks
 

webworkings

Titan
Apr 6, 2016
23,602
96
107,040
Best answers
12,038
I would suggest you take the info for your device, model/serial etc. and visit the manufacturer's website. There you should be able to find out the full specs. Then you can be sure if it does or doesn't have the secondary graphics.
 

p_t

Jan 10, 2019
7
0
10
Best answers
0


I just double checked, it's just the Intel graphics.
 

ASK THE COMMUNITY

TRENDING THREADS