Directx diagnostics tool - something doesn't add up..

Jun 1, 2018
1
0
10
0
Hello,
I've bought a laptop (Asus x510UQ) and I took this one because it has an "Nvidia Geforce 940MX". was thinking it would be nice for gaming, even at low resultion or such (as long as it would be able to run them).

I've bought Asus Screen (PG258Q) which should have the option to transmit at 240HZ, but get only 60HZ => and here is where all troubles start:

After reading the forums, they said that the main graphic card is Intel graphics and the Nvidia, is "switched on" while gaming. from some reason, i don't know if it is true, or how to check that. Currently, if i look at the Directx diagnostics tool, i get the following:




Now.. it makes me wonder: Did i buy a cat in the bag?. Is there anything to do to make the Geforce main driver (even thou i read it can't be done for certain models). Any ideas what to do?. When I play PUBG (for example) => I look at the systray and see the GPU is on 90-100%. I assume that the GPU is not the 940MX one?.

Would love for some pointers.
Thank you.
 
First you need to get it to detect and use the right card.

A. Uninstall, and then reinstall, the latest graphics card driver.
B. Make sure that your Nvidia graphics card is set as the default graphics card.

Here's the steps on how to set it to default.

1. Open the "Nvidia Control Panel".
2. Select "Manage 3D Settings" under 3D Settings.
3. Click on the "Program Settings" tab and select the program you want to choose a graphics card for from the drop down list.
4. Now select "preferred graphics processor" in the drop down list. (You can see what the automatic option is listed as global setting) If you want to use the dedicated graphics card, select High-performance Nvidia processor.

Once it is running on the right one, test the system again and see if the problem persists.
 
First you need to get it to detect and use the right card.

A. Uninstall, and then reinstall, the latest graphics card driver.
B. Make sure that your Nvidia graphics card is set as the default graphics card.

Here's the steps on how to set it to default.

1. Open the "Nvidia Control Panel".
2. Select "Manage 3D Settings" under 3D Settings.
3. Click on the "Program Settings" tab and select the program you want to choose a graphics card for from the drop down list.
4. Now select "preferred graphics processor" in the drop down list. (You can see what the automatic option is listed as global setting) If you want to use the dedicated graphics card, select High-performance Nvidia processor.

Once it is running on the right one, test the system again and see if the problem persists.
 
Thread starter Similar threads Forum Replies Date
A Laptop Tech Support 15
L Laptop Tech Support 3
zkharya Laptop Tech Support 1
S Laptop Tech Support 1
O Laptop Tech Support 1
S Laptop Tech Support 27
S Laptop Tech Support 2
M Laptop Tech Support 1
F Laptop Tech Support 3
S Laptop Tech Support 1
P Laptop Tech Support 1
P Laptop Tech Support 4
S Laptop Tech Support 2
F Laptop Tech Support 4
Sudiir12345 Laptop Tech Support 2
C Laptop Tech Support 2
A Laptop Tech Support 16
C Laptop Tech Support 5
P Laptop Tech Support 2
TheJJBman11 Laptop Tech Support 13

ASK THE COMMUNITY