Firefox, I.E., Opera, etc.

requiemsallure

Distinguished
Dec 7, 2009
107
0
18,630
4
Would anyone know the answer to my problem? i cannot seem to get to www.newegg.com for a while now. about a week, on any browser. it just sits there and says transferring data from newegg.com, and then never gets anywhere. i don't understand why this would happen.
 

btk1w1

Distinguished
Oct 13, 2008
173
0
18,660
15
Visit the page linked below and enter neweggs URL to make sure the site isn't down or overloaded:

http://downforeveryoneorjustme.com/

Can you get there via an online proxy (google a free one)?

If you can then there is something at their end preventing you (your external ip address) from accessing the site. You may need to contact the site admin.

If you can't get there then something with your PC preventing your access. Google "edit hosts file" and make sure there isn't an entry for newegg there.
Try turning off your firewall momentarily to see if you regain access.
Momentarily disable other security software to see if you have access.

If you have another pc in the house (or a friend with a laptop that can use your access point) try accessing the site from it. This is to rule out the modem / router as the problem.

Last but not least, clean cached and temp files. Ccleaner is free and is very good at this. If you download it make sure you opt out of the Yahoo! toolbar install.

If you have disabled any security software while you pinpoint the problem remember to re-enable it.
 

btk1w1

Distinguished
Oct 13, 2008
173
0
18,660
15
Visit the page linked below and enter neweggs URL to make sure the site isn't down or overloaded:

http://downforeveryoneorjustme.com/

Can you get there via an online proxy (google a free one)?

If you can then there is something at their end preventing you (your external ip address) from accessing the site. You may need to contact the site admin.

If you can't get there then something with your PC preventing your access. Google "edit hosts file" and make sure there isn't an entry for newegg there.
Try turning off your firewall momentarily to see if you regain access.
Momentarily disable other security software to see if you have access.

If you have another pc in the house (or a friend with a laptop that can use your access point) try accessing the site from it. This is to rule out the modem / router as the problem.

Last but not least, clean cached and temp files. Ccleaner is free and is very good at this. If you download it make sure you opt out of the Yahoo! toolbar install.

If you have disabled any security software while you pinpoint the problem remember to re-enable it.
 

requiemsallure

Distinguished
Dec 7, 2009
107
0
18,630
4
went to that down for everyone site and by FM it seems to work again, haha for now anyway. ill get back to you if anything changes.

but this is really good information, im sure there are other people who will experience the same types of things.
 

aford10

Distinguished


Sweet! That's the coolest link I've seen all day.
 
Thread starter Similar threads Forum Replies Date
U Social Networking 2
A Social Networking 2
P Social Networking 1
Tolis_GR Social Networking 1
M Social Networking 1
D Social Networking 1
T Social Networking 3
Mason Methot Social Networking 5
B Social Networking 3
K Social Networking 3
U Social Networking 1
S Social Networking 2
M Social Networking 3
T Social Networking 25
N Social Networking 10
O Social Networking 9
K Social Networking 0
S Social Networking 5
sagooding Social Networking 1
ionut19 Social Networking 3

ASK THE COMMUNITY