Headset not showing up in Playback Devices

urnima

Prominent
Mar 3, 2017
3
0
510
0
I have the Hyperx Revolvers, a year old. Just re installed windows, just spent 3 hours figuring out how to get Realtek Audio manager back on my computer, so I can get my headset to work. I still cant find it in play back devices, yes I have checked Device manager, Yes, I have uninstalled and reinstalled audio drivers One billion times, I have disabled front jack pick up, I plug it into the back, and it just uses it as realtek Speaker. I have used this headset before I re installed windows perfectly fine. Please help
 

doolittle

Distinguished
I don't think the headset will show up in the output devices when plugged into the analog jacks, it will still be the speaker in output device for the rear jack and if you enable the front jack and use that it will show up as headphones if you setup the audio manager as such. Check the wrench icon in the audio manager and make sure you have enabled "enable auto popup dialog when device has been plugged in" and it should verify with a window that you plugged in an audio connection. If that is not working possible the jack has been damaged, also happened to me so I got a USB sound card and all is well now (also solved my microphone static and noise problem with the on-board realtek).
 

doolittle

Distinguished
I don't think the headset will show up in the output devices when plugged into the analog jacks, it will still be the speaker in output device for the rear jack and if you enable the front jack and use that it will show up as headphones if you setup the audio manager as such. Check the wrench icon in the audio manager and make sure you have enabled "enable auto popup dialog when device has been plugged in" and it should verify with a window that you plugged in an audio connection. If that is not working possible the jack has been damaged, also happened to me so I got a USB sound card and all is well now (also solved my microphone static and noise problem with the on-board realtek).
 

urnima

Prominent
Mar 3, 2017
3
0
510
0
MERGED QUESTION
Question from urnima : "Audio device not found in play back"

I have the Hyperx Revolvers, a year old. Just re installed windows, just spent 3 hours figuring out how to get Realtek Audio manager back on my computer, so I can get my headset to work. I still cant find it in play back devices, yes I have checked Device manager, Yes, I have uninstalled and reinstalled audio drivers One billion times, I have disabled front jack pick up, I plug it into the back, and it just uses it as realtek Speaker. I have used this headset before I re installed windows perfectly fine. Please help
 
Thread starter Similar threads Forum Replies Date
T Audio 0
B Audio 3
J Audio 1
small_cod64 Audio 0
Artisto Audio 2
E Audio 1
S Audio 0
vencellll Audio 1
S Audio 0
Kaza503 Audio 0
Kohaku Bekunin Audio 0
O Audio 5
R Audio 1
Z Audio 1
C Audio 2
M Audio 1
A Audio 1
T Audio 1
T Audio 1
S Audio 1

ASK THE COMMUNITY