Help! Key not responding but spamming at start !

Meckaa

Honorable
Apr 4, 2013
1
0
10,510
0
I have a Packard Bell easy note LS13HR. I inadvertently droped milk all over my keyboard....I immediatly turned off my computer, and tried to dry as much as I could. When I turned it on, everything was working fine, until the letter "e" started working on its own. Then, the letters "e,r,t,d,f,g,c and v" weren't responding. I cleaned the few milk particles left under the keys, and everything returned to normal, except for the "e". It doesn't respond AT ALL, but at start, it spams, without me touching anything, and as soon as I push one key, it stops.

Do you think the key is totally broken, or can I do something about it? Why does it spam on its own and only at turning on?? Please help i don't wanna buy a full new keyboard only for ONE letter.....
 

christop

Distinguished
Sep 30, 2008
569
0
18,960
11
It sound to me like the key is sticking. I would take the key board out and make sure it is completely dry. Try some computer duster air if you have it.
 
Thread starter Similar threads Forum Replies Date
N Laptop Tech Support 5
N Laptop Tech Support 1
K Laptop Tech Support 2
M Laptop Tech Support 1
B Laptop Tech Support 1
S Laptop Tech Support 1
A Laptop Tech Support 1
L Laptop Tech Support 1
B Laptop Tech Support 3
S Laptop Tech Support 2
J Laptop Tech Support 2
W Laptop Tech Support 1
S Laptop Tech Support 1
P Laptop Tech Support 1
G Laptop Tech Support 1
B Laptop Tech Support 1
M Laptop Tech Support 1
W Laptop Tech Support 1
N Laptop Tech Support 1
M Laptop Tech Support 3

ASK THE COMMUNITY