I have the same headset (HyperX Cloud 2) as my friend but my mic quality is much worse

May 8, 2018
3
0
10
0
So I recently purchased a new headset for gaming since my friends complained about my previous one. So my friend recommended that I get the same one as her, which for me wasn't cheap. We tested it out while she streamed and noticed the the quality of my mic is worse than hers even if slightly.

I'll provided a link to the stream so you can hear us, starting at 3 minutes and 50 seconds is a good point in time when we both are talking. I just don't know what to do.

https://www.twitch.tv/videos/258817649

Thank you for any feedback and thank you for your time!
 

R0GG

Honorable
Dec 27, 2012
94
0
10,660
26
Try adjusting Mic quality here: right click sound Systray icon choose recording devices > Right click on your microphone icon : choose properties > go to the last tab "advanced" and check the available sampling modes and choose higher sample rate if it allows you to.

 

Gam3r01

Honorable
Moderator
Jan 12, 2013
311
0
11,260
68
Just to check, are you both using the USB soundcard that comes with the headset?

If you are, the other thing could be the communication software you are using. Skype, discord, etc could make the mic sound worse to the receiving (streaming) end.
Try to record yourself talking, if it still sounds bad, and you are using the soundcard, I would contact kingston and see what they have to say, potentially an RMA.
 
May 8, 2018
3
0
10
0


I not super tech savvy so how do i check if I'm using my USB sound card? We are also both using discord
 

Gam3r01

Honorable
Moderator
Jan 12, 2013
311
0
11,260
68
The next thing to try would be a recording of yourself, if that sounds good its discord causing issues on the stream end. If it sounds bad, there could be other issues.
 
May 11, 2018
1
0
10
0
Hi! i would recommend you to check the control panel and search the sound devices tab and check that only the HyperXCloud2 is enabled , other good option to check out is asio4all this is like a driver manager, from there you can enable and disable all your inputs and outputs of all the soundcards in your computer.
Have you find out the problem?
 

R0GG

Honorable
Dec 27, 2012
94
0
10,660
26
Try adjusting Mic quality here: right click sound Systray icon choose recording devices > Right click on your microphone icon : choose properties > go to the last tab "advanced" and check the available sampling modes and choose higher sample rate if it allows you to.

 

ASK THE COMMUNITY