Question JBL gt-basspro12 no sound

svaredaud3n

Commendable
Oct 19, 2017
3
1
1,510
0
Hi.
Im having issues with my 3 year old jbl gt-basspro 12 sub with amp thats mounted in the back of my car.
The sub turns on, and even makes a subtle "thud" when its turning on, but im hearing/feeling no audio coming from it.
On the back of the sub it says its on, and shows no issues when i look at the small lamps thats on the back of it. Ive tried switching L/R audio cables because i thought it was broken(cable was horribly bent) but that didnt help. Ive checked the subs fuse and my cars fuse, but i found no signs of a burnt fuse. I shouldnt have any power or fuse issues because it turns on and lights up a green "ON" lamp but it never hurts to check.
I have a kenwood dab radio its connected to and ive used both USB and bluetooth to play music with incase there was something wrong with my phones EQ.

I tried to factory reset the radio, but im still having issues.
Worst case i probably have to buy a new radio.
Before i do that i thought some of you might know what to do. Im not einstein when it comes to audio, but i know some things here and there.
Ive also checked the user manual where it says:

"Power indicator is lit, but there is no bass:
  1. Inputs are not properly connected. Check connections.
  2. Head-unit fader controls are not set properly. Adjust head-unit controls to feed audio signals to
the subwoofer.
3. Incorrect subwoofer Level control setting."

Personally this tells me that my head unit aka radio aint sending signals to my sub. I could be wrong, and this is why im asking here.
Ive had no issues before this, and im very confused.


EDIT: Sorry for my bad formatting and sentences :)
 
Last edited:

Sonic Illusions

Prominent
Feb 16, 2019
160
18
645
4
You didn't mention if you get audio, but just no sub. Do you also have other amps driving other speakers and they have sound? Are there pass-through outputs from another amp to the sub? Have you tried another source you know delivers a signal to the sub amp, as a test? Like your cell phone, with a 3.5mm to stereo (L+R) RCA male cable for a DIRECT, wired connection? If you get audio from your phone to the sub, then look at the cable to the head unit and lastly, you may be correct about the head unit being faulty.
 

svaredaud3n

Commendable
Oct 19, 2017
3
1
1,510
0
You didn't mention if you get audio, but just no sub. Do you also have other amps driving other speakers and they have sound? Are there pass-through outputs from another amp to the sub? Have you tried another source you know delivers a signal to the sub amp, as a test? Like your cell phone, with a 3.5mm to stereo (L+R) RCA male cable for a DIRECT, wired connection? If you get audio from your phone to the sub, then look at the cable to the head unit and lastly, you may be correct about the head unit being faulty.
I get audio in my original car speakers(door speakers) but not the sub. I used the head unit 3.5mm and tested with 3.5mm to lightning(iPhone) but no fix there either.
I haven’t tried directly into the stereo RCA male cable without using the head unit. Im gonna have to try that.
I checked all the cables to the head unit and replaced the stereo RCA cable yesterday so nothing should be wrong there.
I don’t have an external amp, or any other amps than the one inside the sub.

If using a 3.5mm to RCA directly to the sub works I’m gonna try getting my hands on a new head unit.

Thanks for replying and helping me :)!
 

svaredaud3n

Commendable
Oct 19, 2017
3
1
1,510
0
SOLVED. No clue how but RCA/Left and right points in my sub were somehow not working. No clue how to explain it but i switched them out, and voila it works. Was probably a mix between my old broken stereo RCA cable and inputs being not working.

Now i just need to mark this as solved. Hmmmm, how
 
Reactions: Sonic Illusions
Thread starter Similar threads Forum Replies Date
CatTheMightyLord Audio 0
Nonamekeke Audio 0
Durasher Audio 1
S Audio 0
mehi94 Audio 2
kylelb Audio 1
Y Audio 0
Imgoinplaces Audio 0
M Audio 1
L Audio 0
T Audio 3
Doctor Gonzo Audio 0
V Audio 1
G Audio 2
D Audio 5
konradcool15 Audio 0
J Audio 0
pbeans Audio 0
rickthelover Audio 1
J Audio 7

ASK THE COMMUNITY