Laptop not Booting, Fan processor not working

nwni

Estimable
Jul 13, 2015
3
0
4,510
0
Greattings everyone, a week ago a purchase an used laptop wich i open to changue the thermal paste.
When i was puting everything back, i accidentally use a wrong screw, a bigger one and that happend, see pic below.

Well after that i try turning it on again but it wont boot and the processor fan is not working either.
The disk reader works and i can hear the hard drive working but nothing else.
I´ve tried to turn it on with AC, AC + battery, Battery, but still nothing.

I find out that the chip that is damaged is: Conexant cx206671-21z cx20671 21z the Audio Codec.

I hope you can help me, the Laptop Specs:
Thinkpad T420
HD: 500GB
8GB RAM DDR3
INTEL CORE I5

The chip is below the keyboard connector.


I hope you can help, thanks.
 

C12Friedman

Distinguished
I can't say for sure but that seems superficial, I can't really see how far into the epoxy the screw went though. In any case that chip should have little to do with overall operation. I'll suggest a reset and possibly replacing the CMOS battery (or check that it is showing 3V).
To reset the laptop, unplug power adapter, remove battery, then press and hold the power button for ~30 seconds. Put the battery back in, plug in adapter, attempt to power on then.
 

C12Friedman

Distinguished
I can't say for sure but that seems superficial, I can't really see how far into the epoxy the screw went though. In any case that chip should have little to do with overall operation. I'll suggest a reset and possibly replacing the CMOS battery (or check that it is showing 3V).
To reset the laptop, unplug power adapter, remove battery, then press and hold the power button for ~30 seconds. Put the battery back in, plug in adapter, attempt to power on then.
 

nwni

Estimable
Jul 13, 2015
3
0
4,510
0


Thanks, i´ll report the results after i get home.
 

nwni

Estimable
Jul 13, 2015
3
0
4,510
0


Done testing.
The CMOS battery is showing 3.3V.
And does exactly the same as before, the hard drive and the disk reader are kind of working, also the only light thats works is the power button and it kind of flinker in 1 sec interval.
I didnt have to press the power button as soon as it detects energy it automatically turns on.
 
Thread starter Similar threads Forum Replies Date
O Laptop Tech Support 1
M Laptop Tech Support 2
Empyreus Kitsune Laptop Tech Support 2
H Laptop Tech Support 2
sforsandeep Laptop Tech Support 0
M Laptop Tech Support 2
S Laptop Tech Support 0
Nameer90 Laptop Tech Support 0
H Laptop Tech Support 8
M Laptop Tech Support 3
Wraize Laptop Tech Support 0
70UNIK Laptop Tech Support 0
pisola Laptop Tech Support 1
D Laptop Tech Support 2
A Laptop Tech Support 0
M Laptop Tech Support 2
ozi2708 Laptop Tech Support 3
S Laptop Tech Support 11
S Laptop Tech Support 6
E Laptop Tech Support 3

ASK THE COMMUNITY

TRENDING THREADS