Solved! My toshiba S70 will operate when only the AC charger is connected but when I install new battery the laptop will not come on

Jan 22, 2019
1
0
10
0
Toshiba S70 laptop will run and operate with charger only. When I install battery the laptop won’t even come on. I’ve tested my charger and it shows 19.2 volts
 
The new battery is it OEM or aftermarket? If it is aftermarket, that may be your problem. They don't always work correctly and they can be problematic. If this is the case, I would suggest returning the battery and getting an OEM one.

Also you didn't mention if it won't run on the battery, even if it has a charge, or if it just won't run on it when it isn't charged.
 
The new battery is it OEM or aftermarket? If it is aftermarket, that may be your problem. They don't always work correctly and they can be problematic. If this is the case, I would suggest returning the battery and getting an OEM one.

Also you didn't mention if it won't run on the battery, even if it has a charge, or if it just won't run on it when it isn't charged.
 
Thread starter Similar threads Forum Replies Date
nicole50119 Laptop Tech Support 0
lk4k Laptop Tech Support 2
kursat42 Laptop Tech Support 4
savedlema Laptop Tech Support 1
D Laptop Tech Support 2
Andy craepher Laptop Tech Support 0
S Laptop Tech Support 2
P Laptop Tech Support 1
R Laptop Tech Support 4
S Laptop Tech Support 2
J Laptop Tech Support 2
A Laptop Tech Support 5
S Laptop Tech Support 7
A Laptop Tech Support 4
P Laptop Tech Support 1
B Laptop Tech Support 1
C Laptop Tech Support 1
S Laptop Tech Support 1
G Laptop Tech Support 5
G Laptop Tech Support 3

ASK THE COMMUNITY