Nvidia Control Panel not saving settings (permissions set correctly)

filipao223

Estimable
Aug 30, 2015
7
0
4,510
0
I've been googling this matter for a lot time now, and all the possible solutions involve changing the permissions of C:\ProgramData\Nvidia corporation.Having done all that, the problem still persists. Trying to change default GPU doesn't work as its reverted when Control Panel is restarted. Any ideas on solving this?

P.S.: My OS is Windows 8.1 64 bits.
 
Hi,

First try to uninstall/reinstall the graphics card driver.
- Uninstall the graphics card driver from Device Manager and in Programs and Features as well since it should have something related to NVIDIA in there as well.
- Once uninstalled download and install the latest driver from NVIDIA support site.
- Here's the link: nvidia.com/download/index.aspx
- Use the Auto Detect feature so they could give you the latest and accurate driver for your graphics card.
- Lastly reboot it once the latest driver has been installed.

After all this try changing the settings again making your Graphics card the default device again.
 

filipao223

Estimable
Aug 30, 2015
7
0
4,510
0


Thanks for your reply. I've found out that it was the installation of Geforce Experience that was messing with the permissions of the folders and the drivers. Uninstalling and reinstalling the drivers seemed to do the trick. Thanks again for your help.
 
Thread starter Similar threads Forum Replies Date
S Laptop Tech Support 0
I Laptop Tech Support 1
N Laptop Tech Support 4
C Laptop Tech Support 5
P Laptop Tech Support 1
S Laptop Tech Support 1
A Laptop Tech Support 3
M Laptop Tech Support 3
H Laptop Tech Support 1
E Laptop Tech Support 4
D Laptop Tech Support 1
F Laptop Tech Support 8
S Laptop Tech Support 3
K Laptop Tech Support 16
F Laptop Tech Support 5
W Laptop Tech Support 2
N Laptop Tech Support 2
D Laptop Tech Support 1
A Laptop Tech Support 2
G Laptop Tech Support 1

Similar threads


ASK THE COMMUNITY