Random webpage opening automatically on boot

Status
Not open for further replies.

Wite with problems

Commendable
Dec 25, 2016
5
0
1,510
0
Recently, after booting up my Windows 10 PC, a random Russian website opens up in my default browser
It like starts as soon after I boot.
Google Chrome (my default browser) doesn't run on boot (I've checked the startup tab under task manager.
I'm not sure if this is a virus, as I have run multiple scans on Windows Defender and got no issues. I haven't installed any programs recently, this started up after my first boot in a few months. Please suggest troubleshooting, I really dont want to go for a system reset yet..

Thanks
 

mjslakeridge

Honorable
Mar 6, 2013
324
0
11,260
56
It does sound like a virus. Try downloading Malwarebytes and run a scan. Note that Windows Defender will be disabled when you have malwarebytes installed, so uninstall it after you do the scan.

Also go into Chrome settings (the 3 dots on the upper right part of the screen) and scroll down to "on startup". Mine is set to "continue where you left off". Perhaps this is checked on your computer.
 

mjslakeridge

Honorable
Mar 6, 2013
324
0
11,260
56
It does sound like a virus. Try downloading Malwarebytes and run a scan. Note that Windows Defender will be disabled when you have malwarebytes installed, so uninstall it after you do the scan.

Also go into Chrome settings (the 3 dots on the upper right part of the screen) and scroll down to "on startup". Mine is set to "continue where you left off". Perhaps this is checked on your computer.
 

Wite with problems

Commendable
Dec 25, 2016
5
0
1,510
0


The chrome settings say to start with specific URL, set to https://www.google.co.in/
Can I not use Windows Defender instead of MalwareBytes to run a full scan? Because I havent tried a full scan yet, only done the quick scan which yielded no results
 

mjslakeridge

Honorable
Mar 6, 2013
324
0
11,260
56
I had a virus some time ago that Windows Defender found and "supposedly" removed, but it kept showing up each day. So I reverted to a cloned disk image from a month before and that solved it for good.
 

Wite with problems

Commendable
Dec 25, 2016
5
0
1,510
0
K so I've run a scan on Malwarebytes, it found around 15 threats, I removed them, and after a restart it seems to be fine...

I'm not sure if it will never happen again, but thanks anyway
 
Status
Not open for further replies.
Thread starter Similar threads Forum Replies Date
Ginko-san Antivirus / Security / Privacy 37
N Antivirus / Security / Privacy 1
S Antivirus / Security / Privacy 1
U Antivirus / Security / Privacy 2
U Antivirus / Security / Privacy 1
D Antivirus / Security / Privacy 2
T Antivirus / Security / Privacy 1
D Antivirus / Security / Privacy 2
C Antivirus / Security / Privacy 8
L Antivirus / Security / Privacy 3
F Antivirus / Security / Privacy 7
S Antivirus / Security / Privacy 1
K Antivirus / Security / Privacy 6
W Antivirus / Security / Privacy 2
J Antivirus / Security / Privacy 1
I Antivirus / Security / Privacy 1
B Antivirus / Security / Privacy 6
L Antivirus / Security / Privacy 2
D Antivirus / Security / Privacy 1
K Antivirus / Security / Privacy 5

ASK THE COMMUNITY