Razer Kraken 7.1 Surround Sound USB Gaming Headset Static Noise When Playing Audio.

GouldyGaming

Estimable
Aug 17, 2014
5
0
4,510
0
I recently picked up the Razer Kraken 7.1 USB edition headset from amazon and straight out of the box whenever any type of audio is playing there is a static sound in the background. I cannot hear the static sound when there is no sound coming through the headset speakers, just when there is. If it helps this is the product page: http://www.amazon.co.uk/Razer-Kraken-Surround-Gaming-Headset/dp/B00EO18U6M/

I have tried multiple different USB ports on my PC and also different USB headsets so I don't think that the issue is with my PC. I tried messing about with the settings on Razer Synapse 2.0 but that only made the audio in certain programs very very quiet so I decided to just un-install it (is this typical with most headsets being configured with Synapse?). If anyone has had this issue before and solved it or knows a possible fix PLEASE help me! I love this headset apart from this one issue and it would be a real shame to send it back. Thanks.
 

GouldyGaming

Estimable
Aug 17, 2014
5
0
4,510
0


I have an Nvidia GTX 660. About the cord do you mean the cord of the headset or the cord for the GPU?
 

Oakley999

Estimable
May 17, 2014
61
0
4,580
0
might as well return it while your waranty lasts. im returning it now. only had this for 1 day lol. was already googling a solution within 10 minutes, fucking awful. Also, i dont know how a video card affects a headset.
 
Thread starter Similar threads Forum Replies Date
D Audio 1
filthyspoons Audio 0
S Audio 0
tophatclay Audio 0
B Audio 1
O Audio 1
B Audio 2
R Audio 1
M Audio 2
J Audio 4
D Audio 2
J Audio 4
V Audio 3
Asbaat Audio 1
H Audio 2
S Audio 10
A Audio 4
A Audio 1
T Audio 1
Myntekt Audio 6

ASK THE COMMUNITY