Some usb devices won't work on one usb port on my laptop.

Caleb Burris

Estimable
Apr 23, 2015
3
0
4,510
0
I have the new Asus Zenbook UX305, and have an issue where one of the usb ports won't show most devices. In fact the only device that works with that port is my external hard drive. I have tried using that port in Linux as well, and it has the exact same issue. This is such a strange issue that I have never seen before! I'm thinking that it has to be the BIOS, but I have no idea what. if it helps, some of the other usb ports don't like some other devices, like my external SD card reader won't be recognized on any of the ports, unless I use a USB hub, but that doesn't work at all on the bad port.
 

Jesper Orngreen

Estimable
Aug 30, 2015
1
0
4,510
0
Hi Caleb,

Have you solved this issue? Because I just bought a UX305 myself, and I'm having the exact same issue, with the single USB port on the right side of the machine. The two USB ports on the left side, recognize everything just fine.

A strange thing: when for instance i plug my Lumia 930 into the right side USB, its not accessible and never shows up, EXCEPT - that the "Safely Remove Hardware and Eject Media" icon in the notification area, DOES gives me the option of "Eject Lumia 930".

So 'something' detected it, but never 'mounted' it correctly (or whatever its called under windows)
 
Thread starter Similar threads Forum Replies Date
Alwise901 Laptop Tech Support 3
T Laptop Tech Support 1
B Laptop Tech Support 1
D Laptop Tech Support 4
L Laptop Tech Support 5
A Laptop Tech Support 2
D Laptop Tech Support 2
EndlessZone123 Laptop Tech Support 5
D Laptop Tech Support 1
S Laptop Tech Support 2
G Laptop Tech Support 1
M Laptop Tech Support 1
P Laptop Tech Support 4
M Laptop Tech Support 1
D Laptop Tech Support 3
B Laptop Tech Support 1
B Laptop Tech Support 1
C Laptop Tech Support 1
B Laptop Tech Support 1
S Laptop Tech Support 1

Similar threads


ASK THE COMMUNITY

TRENDING THREADS