TCL Roku 6-series - Logitech z960 surround sound system not switching between DOLBY and Stereo

Dec 26, 2018
3
0
10
0
I have the following equipment.
1. TCL Roku 6 Series 4K smart TV
2. Logitech z906 surround sound system
I have connected my TCL TV to the logitech z906 via a digital audio cable (THERE IS NO HDMI on the z906)

The Logitech z906 system has dolby DTS and a "3-D effect" for stereo sound.

My TCL audio output allows for "AUTO-DETECT" and "Dolby DTS"

When I select "AUTO detect" on my TV, the surround sound system will not produce true 5.1 dolby DTS surround sound. It will only produce the "3D stereo effect" for all my streaming apps (netflix and directTV). When selecting the "AUTO-DETECT" option, the information on screen states that "select auto-detect to read supported audio formations from your receive using HDMI CEC. Requires an HDMI connect to your receiver. Stereo is selected if unable to detect supported formats."

When I select "DOLBY DTS" on the TCL TV, it will produce TRUE 5.1 surround sound on netflix and my PS4. BUT when I watch youtube or directtv on my TCL app, only the 2 front speakers operate. It would be ideal if the surround sound system would switch to "3-D stereo sound" but it does not and only the 2 front speakers work.

Is there a way to have my logitech z960 switch to stereo 3D effect, when placing the "DOLBY DTS" setting on my TCL?

Is the problem that the logitech z960 doesn't have an HDMI port and thus the TCL "AUTO-DETECT" option will not work?

Should I return this surround sound system and get another system with a receiver with HDMI ports?

 
Dec 26, 2018
3
0
10
0


Have any other suggestions that doesn't require me to spend $500 in a processor? Will a HDMI audio extractor work?
 
Dec 26, 2018
3
0
10
0


but 3D or 4.1 isn't as good as dolby digital 5.1 right?
 
Feb 20, 2019
1
0
10
0
The z960 is not doing it for you.

I have R617 (audio set DD/DTS) + Emotiva UMC200 AV processor and things work as they should.

Whether I use HDMI or Optical doesn't matter in this case.
I too have the UMC-200 and R617... Did you try using Auto-detect for ARC? When I tried Auto-detect, I got buzzing/weird handshake sounding issues. I tried DD+ and got the same, so I had to set it manually at DD/DTS, like you. Do you have these same problems? I'm trying to figure it out, as Netflix does DD+.
 
Thread starter Similar threads Forum Replies Date
K Streaming Video & TVs 1
Marshall Honorof Streaming Video & TVs 0
B Streaming Video & TVs 1
I Streaming Video & TVs 4
R Streaming Video & TVs 2
C Streaming Video & TVs 1
B Streaming Video & TVs 1
S Streaming Video & TVs 1
M Streaming Video & TVs 1
R Streaming Video & TVs 1
A Streaming Video & TVs 8
T Streaming Video & TVs 1
S Streaming Video & TVs 2
C Streaming Video & TVs 1
C Streaming Video & TVs 1
P Streaming Video & TVs 1
K Streaming Video & TVs 0
P Streaming Video & TVs 1
C Streaming Video & TVs 3
G Streaming Video & TVs 2

Similar threads


ASK THE COMMUNITY