Toshiba satellite l300 tuns blank after few minutes

totoalfaro123

Honorable
May 11, 2012
1
0
10,510
0
Hello,
I have a toshiba L300-1CU laptop.
This is originally installed with Vista X32.
The unit suddenly turns blank after finishing booting up the windows.
At first, I thought if this is a VISTA issue.
I am updating it to Windows 7 hoping that it will solve the problem..but the problem persists..After finish booting up Win7, after few minutes, it will goes blank..Out of desperation, I am formatting the hardrive to Win XP thinking that it might be a virus...This time, the unit will goes blank longer than previous one..Is this because most drivers like WLAN and VGA drivers were not installed ? I am getting nuts on this problem..Any help..pls advise...

Angelo
 

hpfreak

Distinguished
Nov 29, 2010
805
0
19,010
49
Hey totoalfaro123,
Yes, it is very important to install the drivers for the laptop. I think you're experiencing a heat issue.
Have you ever cleaned the dust from the exhaust vents? Laptops need to be sprayed with a can of compressed air every few months, to keep from having a dust build up. Which leads to the heat issues which can cause the symptons you're having with your laptop.

Just to clarify, when it goes blank. Is it the screen that seems to go off, while everything seems to continue working? Like light indicators, and fan spinning?
 
Thread starter Similar threads Forum Replies Date
A Laptop General Discussion 1
nako2007 Laptop General Discussion 1
XClone.Globe Laptop General Discussion 9
C Laptop General Discussion 1
J Laptop General Discussion 5
C.A.I.H Laptop General Discussion 2
allyyoung13 Laptop General Discussion 1
G Laptop General Discussion 0
E Laptop General Discussion 1
M Laptop General Discussion 1
E Laptop General Discussion 2
M Laptop General Discussion 1
J Laptop General Discussion 1
L Laptop General Discussion 1
C Laptop General Discussion 1
J Laptop General Discussion 2
S Laptop General Discussion 2
A Laptop General Discussion 1
H Laptop General Discussion 2
S Laptop General Discussion 1

ASK THE COMMUNITY