Unable to rid "Microsoft Corporation WDDM 1.1" and install Catalyst

Hydralisk

Distinguished
Sep 14, 2011
1
0
18,510
0
Hello,

I am having trouble upgrading to the newest 11.8 Catalyst package for my HD 4850 video card.

It all started after I did a format partition and reinstalled Windows 7 64-bit. For some reason, Windows already supplied me with a video card driver upon installation. I checked control panel -> device manager -> display adapters, and it said "ATI Radeon HD 4800 Series (Microsoft Corporation WDDM 1.1)". On dxdiag, the driver date was 7/13/2009. I wanted to install the newest driver for my video card, and the driver is linked below:

http://sites.amd.com/us/game/downloads/Pages/radeon_win7-64.aspx

Before I even installed it, I uninstalled the Windows WDDM 1.1 driver in the device manager (which was confirmed when my screen changed from 1680x1050 to 800x600.) After Catalyst 11.8 finished installing, I got a Windows message saying I successfully installed the Windows WDDM 1.1 driver ... which I did not want.

I tried redoing it in safe mode and I tried older Catalyst versions (11.7) but I can't figure out how to stop the WDDM 1.1 from being auto-installed and have my computer install the desired Catalyst package instead. After each attempt of installing Catalyst, I deleted the ATI files and made sure there were no remnants of previous drivers.

Note: the HD 4850 was given to me as a gift and did not come with a CD. I previously used Windows 7 64-bit and had no issue with this before while using the same hardware.

Is there something I am overlooking? Thanks for the help!
 
Thread starter Similar threads Forum Replies Date
T Apps General Discussion 1
A Apps General Discussion 2
C Apps General Discussion 2
J Apps General Discussion 1
V Apps General Discussion 1
shivampandit1999 Apps General Discussion 4
S Apps General Discussion 1
E Apps General Discussion 1
T Apps General Discussion 1
C Apps General Discussion 9
L Apps General Discussion 1
A Apps General Discussion 6
S Apps General Discussion 1
F Apps General Discussion 1
S Apps General Discussion 2
G Apps General Discussion 3
I Apps General Discussion 8
V Apps General Discussion 3
L Apps General Discussion 8
D Apps General Discussion 1

ASK THE COMMUNITY