Hi guys,

Meaning Key:
WDS/Bridge Router: The router I want to enable WDS on.
Root Router: The main router I want my WDS router to connect to. (Root Router has Internet connection)

I am having a problem with setting up my TP-Link WR741N Router to bridge with another router that has Internet connection.

So I have done the following as written in TP-Link's articles:
1-Set both routers (Root and Bridge router) to the same channel.
2-Turned off DHCP in the bridge router.
3-Set the root router IP to and set the WDS router to
4-Made sure that the root router allows bridge connections. (It does allow)
5-Enabled WDS and added the SSID and BSSID with the correct password and password type for the root server.

The bridged router shows that it is connected without any issues to the root router, but actually, I can't access any website while connecting to the WDS router, I can't even access the root router gateway to configure the root router, though the computer connected to the WDS router gets correct IPCONFIG with correct IP Address from the root's DHCP.

I can access the WDS router ( while connecting to the root router (, but I can't do the other way around while connecting to the WDS router (I can't access

The signal between them is not bad at all, so is the distance.

If I ping while connecting to the WDS Router I get the message: "Reply from Destination host unreachable."

Both routers have the latest firmwares.




I tried playing with the IP and the subnet mask but no success. The TP-Link router says that the WDS is connected and authenticated.


Aug 9, 2012
Are both routers from tp-link. WDS tends to be very hard to get setup when the vendors do not match.
Not sure what to tell you your router has few options other than turning it on. Normally what is called bridge mode is bridging the wan and lan ports (including the wireless). With this router they also have a different "bridge" mode for that one.

After looking at the manual for this router I would recommend you do not use it for this purpose. It only support open and WEP. WEP is completely cracked so you are running with no security on your wireless.



No they are not both from TP-Link. I have tried using WEP and Open security, both didn't work.
Actually even with WPA2, the TP-Link router returns that it succeeded to connect to the root router and my PC can get its IP and the gateway from the root DHCP server. The problem is that I can't connect to the internet through the TPLink router :S


Rafi Khan

Sep 22, 2013
IF ur second router does not have repeating function u will need to use a patch or crossover cable between them, which defeats the purpose so the only option is to use an EOP which is very expenseive. Better to just buy one of the new ac1600 routers or n600-900


Dec 7, 2013
Same problem with my MR3220. I can't access internet while both the routers are connected to each other and can transfer requests on devices connected to it that doesn't require internet. The device such as mobile connected to bridged router cannot open the website while other devices w/o internet are working successfully. :??: