Wired and Wireless No Good


Sep 4, 2016
A W520, Lenovo Thinkpad, Windows 7 64-bit.
It has been working until yesterday, the first day at southern California:
- Cox provided a NETGEAR modem/router, has dual band for WIFI, say Band1 and Band2
- Tried both bands are "Windows are unable to connecto xxx", or show as "Connected" in WIFI list, but saied "no internet access" and a yellow star on top of WIFI bar in lower right corner.
- Tried all four combination of WPA2-Personal, WPA-Personal, AES and TKIP.
- Plugged in wire directly from router while had WIFI turned OFF, got "currently connect to xxx, no internet access". Same thing while WIFI is ON.

Is the modem/router working?

Yes, all other laptops and wireless devices using the same router/modem connected no problem, wired or wireless.

Brought the laptop to a COX center, staffs there are very helpful, connected to a diff router, repeated the same steps still the same result.

We also checked Device Manager at Control Panel, Networking showing everything "working properly". Even tried disable then enable the corresponding NIC, warm-boot, cold-boot, same.