Solved! Black screen on boot, and when booting into Windows. Screen works when booting into Ubuntu

Dec 20, 2018
4
0
10
0
Hello again,

I posted a while back, and this time I have more information as I have been trying to figure out the issue, but it's still not working.

Things that haven't changed:

Everything is visible when using an external display.

There is no power to the screen during boot, the grub menu not visible (I have an Ubuntu/Windows dual boot.)

When booting to Ubuntu, the screen turns on, and works fine.

New developments:

Windows is toast. It has the blue death screen, and I cannot use system restore, as it says that this is not possible.

I cannot do a fresh install of windows. This results in the error 0x80070570. Upon reading this seems to possibly imply a memory issue.

I ran chkdsk, which exited before completing, throwing an unspecified error.

From the command prompt, I tried /bootrec.exe/fixbcd and it said that no installation of windows was found.

When booting from a usb, the screen does not work at all.

I'm really stumped.

What I'm thinking, but need help troubleshooting:

I'm running memory check as I write this to see if there's a memory issue.

Could this be a hard drive issue? I dont care about the data on the windows partition, so I dont really care if I have to nuke that partition and start over.

Thanks in advance!

 

engineer5261

Commendable
Apr 26, 2016
70
0
1,610
12
Are you using a USB stick to install windows? Try a different USB stick, or format this one and put windows install files on it again. Hopefully that should allow you to re-install windows
 

engineer5261

Commendable
Apr 26, 2016
70
0
1,610
12
Are you using a USB stick to install windows? Try a different USB stick, or format this one and put windows install files on it again. Hopefully that should allow you to re-install windows
 
Dec 20, 2018
4
0
10
0
MERGED QUESTION
Question from niemi.rikki : "Laptop built in screen does not work during BIOS and in windows, but works with Ubuntu"

Hey everyone,

I have a weird issue. I have a Toshiba S55-C5474 laptop, and the display is acting funny. Upon boot, there is a black screen with no back light, the splash screen is missing, and if I boot through to Windows 10 the screen remains off. However, since I have a dual boot with Ubuntu, I can select to boot into Ubuntu, and then the screen turns on! Also, the splash screen, and any other display can be seen on an external display, but the only time the built in screen works is when I'm running Ubuntu, and it only turns on after it has booted up completely. The screen doesn't turn on in BIOS, or before that.

Also, when in Windows, the screen is not detected at all, and when hooked up to an external display, device manager only shows a generic pnp monitor being present.

Things I have tried:

Windows went south yesterday, and it wouldn't let me reinstall off of a recovery USB, giving me an error code of 0x80070570. Chkdsk wasn't able to complete successfully, stating there was an unspecified error.

At this point I went into Ubuntu and checked my disk. SMART was passing, despite there being a value of 8 in the current pending sector count. All other values were normal. Screen worked the whole time.

Since there was something definitely going haywire on the windows side, I ran ntfsfix to see if I could repair the windows partition, and proceed with a clean install. Screen is fine the whole time on Ubuntu still.

I was able to finally reinstall Windows using the USB now. Screen still not working. Windows is successfully fixed, for the time being.

I tried uninstalling and reinstalling the display adapter driver, which didn't change anything.

Scouring the internet, the potential of a BIOS issue came up, so I made sure my BIOS was up to date. It is.

Then I cleared the CMOS. Upon restarting, the screen worked for the first time in forever the way it should: splash screen and worked in Windows. Would it work a second time? I restart to find out.

...It would not. Hooked it back up to my TV.

Of course the Windows install screwed Ubuntu, the only OS that lets me use the screen, so I reinstalled that. Was uneventful and successful.

Since resetting the CMOS did create a situation where the screen was operational, I decided to change out the CMOS battery with a brand new one (The computer is about 5 years old, and the battery was low after checking it with my DMM).

The screen didn't work again by not showing the Toshiba splash screen, nor does it work in Windows 10. Ubuntu makes it turn on, still.

So, this is where I'm at. Any ideas?

 
Thread starter Similar threads Forum Replies Date
TehAsezOner Laptop Tech Support 0
G Laptop Tech Support 6
S Laptop Tech Support 2
J Laptop Tech Support 1
junior31210 Laptop Tech Support 1
P Laptop Tech Support 3
T Laptop Tech Support 4
J Laptop Tech Support 1
Pompa Laptop Tech Support 7
B Laptop Tech Support 1
J Laptop Tech Support 4
A Laptop Tech Support 1
B Laptop Tech Support 1
S Laptop Tech Support 1
S Laptop Tech Support 5
J Laptop Tech Support 2
R Laptop Tech Support 1
N Laptop Tech Support 1
W Laptop Tech Support 3
E Laptop Tech Support 1

ASK THE COMMUNITY