Dell Xps l702x wireless speed problems after factory reset

horia.stoica3

Prominent
Oct 20, 2017
4
0
510
0
Hi!I have kind of the same problem...i just did a factory reset and now the speed is terrible..im not kinda of good with these?
 
So your computer gets good speed elsewhere but not at your own home with your own internet? Then there is a problem with your internet. You need to contact your carrier/service provider. See if the speed issue is on their end or if it is the modem/router that is the problem. If you own it, then you may need to replace it. If not, then make them replace it. :)

Oh and don't let whatever tech you get make you think it can't be the service. Sadly, with some companies they do that. Try everything to make out that the problem is not them. If you need to, ask to speak to someone higher, but make sure they actually fix the issue.
 
Unless there is a problem with your wireless card, the speed shouldn't be effected by the computer. However, it can be effected by how many devices are connected to the WiFi (and what they are doing), the ISP having issues (which is so common) and also the modem/router. And the location of the modem/router can be effecting if there is anything interfering with the WiFi signal.

The first thing I would try would be to reset the modem/router. Then test the speed once it is fully reloaded. Also, the more devices using it the worse your connection will be. And if any of them are graphic intensive, like say playing an online game from a laptop or having a gaming consol that you are going online and playing, (as an example) would seriously use up your connection.
 

horia.stoica3

Prominent
Oct 20, 2017
4
0
510
0
Thanks a lot for taking your time to respond ill try reseting the router and ill come back with the results.I had a problem with my laptop and i got to factory reset it and after that the speed dropped at some mb.Before that everything was totally fine.I tried connecting to the internet at a friend and the speed was 33 mb wow with 27+ more than i get at home.My phone's internet is very good and same for pc.What about ISP?I read something about but i couldnt understand anything.Also i installed the network drivers from dell's site manually..i dont think i messed something up and the it looked like the drivers i took were up to date.I want to thank you again for fast response.
 

horia.stoica3

Prominent
Oct 20, 2017
4
0
510
0
I reseted the router and after that i ran a speed test and the speed is still very low at 6 mbps.As for the drivers i think they are good.When i installed them i entered the service tag on dell site and i took the drivers i needed from there.When i ran a speed test at my friend's home it indicated around 30 mbps and everyting looked alright,the youtube was loading fast.
 
So your computer gets good speed elsewhere but not at your own home with your own internet? Then there is a problem with your internet. You need to contact your carrier/service provider. See if the speed issue is on their end or if it is the modem/router that is the problem. If you own it, then you may need to replace it. If not, then make them replace it. :)

Oh and don't let whatever tech you get make you think it can't be the service. Sadly, with some companies they do that. Try everything to make out that the problem is not them. If you need to, ask to speak to someone higher, but make sure they actually fix the issue.
 
Thread starter Similar threads Forum Replies Date
bd01ng Laptop Tech Support 3
I Laptop Tech Support 3
K Laptop Tech Support 1
Basem16 Laptop Tech Support 1
C Laptop Tech Support 1
F Laptop Tech Support 0
J Laptop Tech Support 0
S Laptop Tech Support 1
S Laptop Tech Support 2
S Laptop Tech Support 1
Tomcatuni Laptop Tech Support 9
W Laptop Tech Support 1
T Laptop Tech Support 3
J Laptop Tech Support 3
G Laptop Tech Support 1
M Laptop Tech Support 3
R Laptop Tech Support 1
N Laptop Tech Support 1
Q Laptop Tech Support 2
S Laptop Tech Support 2

ASK THE COMMUNITY