How to Boot USB Drive in Secure Boot Mode (UEFI)

Not open for further replies.


Dec 10, 2016
HP Notebook 15-f009wm
OS: Windows 8.1 with Bing 32 bit

Hello all,

This is my problem:

I can't get my USB drive to load while in Secure Boot mode and continue running into 'Boot Device Not Found. Please install an operating system on your hard disk' screen. The only method that works thus far is disabling Secure Boot mode and enabling Legacy Support. Here are the methods I have tried based on extensive research of various forums after several days:

- Performed all the generic System Diagnostic tests (F2) + Memtest86 + sfc /scannow multiple times after every fresh install + physically checked HDD. Performed all HP recommendations:

- Did multiple fresh installs of Windows 8.1 with Bing (32 bit) erasing all partitions from hard drive every time (my system is designed for 64 but I only have access to a 32 ISO). Installed using Legacy Support (I understand you can't go back and enable Secure Boot and disable Legacy once it has been installed this way but due to lack of any other way of installing Windows, I have no choice).

- Used 'Windows 7 USB/DVD Download Tool' to create ISO which automatically formats drive to NTFS; converted to FAT32 using 'AOEMI Partition Assistant' software (preserving all partitions/data) but it still won't read.

- Used 'Rufus v. 2.11.995' software to create ISO as FAT32 under several different setting iterations:

1. GPT partition scheme for UEFI (this presumably should be the most appropriate setting but it still did not work). End Format: FAT32
2. GPT partition scheme for UEFI (once with Dual UEFI/BIOS mode enabled and once again with it disabled). End Format: FAT32
3. MBR partition scheme for UEFI (enabled/disabled). End Format: FAT32
4. MBR partition scheme for BIOS or UEFI-CSM (enabled/disabled). End Format: NTFS

- Hard Reset.

- Disabled Security Boot AND Legacy Support together.

- Tried changing BIOS settings mid-insallation of Windows from Legacy to Secure Boot (right after first reboot).

- Rearranged boot order under every possible configuration. Loaded default settings.

- With the Internal Network Adapter Boot disabled by default in BIOS while in Secure Boot mode, the flash drive won't even read in F9 Boot Manager. Once INAB is enabled, the flash drive is recognized and allows access to the files in the folder but none of the files will boot as the next screen that pops up every time states: "Selected boot image did not Authenticate. Press Enter to continue." and it just takes me right back to Boot Manager.

I don't understand what the problem is. I'm using a FAT32 format designed for UEFI as well as GPT partition also best suited for UEFI. I've even created the ISO with both UEFI and BIOS compatibility for each iteration. I've arranged the boot order for USB Flash Drive to boot first. The ISO boots fine in Legacy. What am I missing here?

Thanks for your help.


Dec 10, 2016

Okay, thanks to another user from another site I had posted on, I received the answer I was looking for and am posting it here for anyone's future reference. The problem lies in the 32 bit version of Windows I had installed:

" 32bit is unable to boot on a UEFI GPT disk computer. Only 64bit will work."

I downloaded a Windows 8.1 Single Language 64 bit ISO strictly as a test (as Microsoft doesn't make Bing version available (yet?) for download), used Rufus to set partition scheme to GPT for UEFI and file system as FAT32 and created the new image.

WARNING: If your laptop came with Windows 8 or 8.1 with Bing you will not be able to install any other version of Windows 8 or 8.1 other than Bing. You might be able to use a generic key during setup to get it installed but your Windows will not be activated afterwards as your OEM key is integrated into your firmware and will not activate any other version of Windows 8 other than with Bing. Make sure you have secured either a recovery partition or ISO of this exact version before wiping off your hard drive. If you have used the correct Windows 8 with Bing ISO you will not be asked to enter a product key during setup but rather will be taken straight to the Terms & Policy agreement page.

Once I plugged in the flash drive, it booted right away into installation setup while in Secure Boot enabled / Legacy Support disabled mode. This was what I was trying to do all along.

Regarding my other laptop with the Windows 10 experiencing the same problem: I was so preoccupied with fixing the Windows 8.1 laptop that I never bothered to reformat my flash drive to GPT and FAT32 and had mistakenly installed the correct 64 bit but as a NTFS file system. All I had to do was create a new image with the right settings (above) and sure enough Windows 10 recognized the flash drive immediately and I now have Win 10 installed with Secure Boot enabled / Legacy Support disabled.

Lesson learned:

1. Download correct 64 bit ISO and don't settle on 32 bit even though the OS will still work for the most part.

2. Format your flash drive as GPT partition and FAT32 using Rufus - Don't use Windows USB/DVD Download Tool as it automatically creates NTFS format without you being able to control its settings and it also doesn't provide you options on controlling the partition schemes. Rufus will save you a lot of time and running around.

3. If installing a fresh Windows, boot the ISO with Secure Boot enabled/Legacy Support disabled otherwise you can't change it afterwards.
Not open for further replies.
Thread starter Similar threads Forum Replies Date
S Laptop Tech Support 1
F Laptop Tech Support 4
R Laptop Tech Support 8
Iron-Duke Laptop Tech Support 0
O Laptop Tech Support 1
F Laptop Tech Support 1
C Laptop Tech Support 12
FrostBite-X Mritz Laptop Tech Support 1
M Laptop Tech Support 1
M Laptop Tech Support 2
C Laptop Tech Support 5
L Laptop Tech Support 1
1 Laptop Tech Support 1
B Laptop Tech Support 1
M Laptop Tech Support 1
D Laptop Tech Support 3
M Laptop Tech Support 9
B Laptop Tech Support 21
O Laptop Tech Support 2
G Laptop Tech Support 2