Laptop display goes black after boot logo appears

Status
Not open for further replies.

Mohamed_45

Estimable
Feb 10, 2016
29
0
4,580
0
I have switched my stock display : LP156WF6-SPK3 (LGD0533) 60hz
with a new : AUO B156HAN04.2 120hz
when restarted the laptop the boot logo appears but then the display turns off and the machine is still active when connected to another display and duplicated the monitors it shows both screens connected but only the external monitor is working, My machine is (CyberPowerPC TRACER II) (GTX 1070)
I updated the Graphics drivers and performed a clean install for Nvidia drivers , strangely it works right after the clean install , but after a restart it goes back to black..
i need help as i need to return this display for a refund
 

Lutfij

Splendid
Moderator
Make and model of your laptop? Is the screen you're using a certified replacement panel from the manufacturer? You may also want to see if your laptop has any BIOS updates pending. Can you work off an external monitor to regain some functionality, uninstall your GPU drivers are reinstall them while on the onboard display?
 

Mohamed_45

Estimable
Feb 10, 2016
29
0
4,580
0

CyberPowerPC TRACER II

the native display is the LP156WF6-SPK3 (LGD0533) 60hz

new display is AUO B156HAN04.2 120hz

 

Mohamed_45

Estimable
Feb 10, 2016
29
0
4,580
0
MERGED QUESTION
Question from Mohamed_45 : "Display Turns Dark After Boot Logo"

I have switched my stock display : LP156WF6-SPK3 (LGD0533) 60hz
with a new : AUO B156HAN04.2 120hz
when restarted the laptop the boot logo appears but then the display turns off and the machine is still active when connected to another display and duplicated the monitors it shows both screens connected but only the external monitor is working, My machine is (CyberPowerPC TRACER II) (GTX 1070)
I updated the Graphics drivers and performed a clean install for Nvidia drivers , strangely it works right after the clean install , but after a restart it goes back to black..
i need help as i need to return this display for a refund
 

Mohamed_45

Estimable
Feb 10, 2016
29
0
4,580
0

windows 10
 

Mohamed_45

Estimable
Feb 10, 2016
29
0
4,580
0
MERGED QUESTION
Question from Mohamed_45 : "Display Turns Dark After Boot Logo"

I have switched my stock display : LP156WF6-SPK3 (LGD0533) 60hz
with a new : AUO B156HAN04.2 120hz
when restarted the laptop the boot logo appears but then the display turns off and the machine is still active when connected to another display and duplicated the monitors it shows both screens connected but only the external monitor is working, My machine is (CyberPowerPC TRACER II) (GTX 1070)
I updated the Graphics drivers and performed a clean install for Nvidia drivers , strangely it works right after the clean install , but after a restart it goes back to black..
i need help as i need to return this display for a refund
 
Status
Not open for further replies.
Thread starter Similar threads Forum Replies Date
SZilveti Laptop General Discussion 2
E.D. Laptop General Discussion 2
saidrafly Laptop General Discussion 0
LordElites Laptop General Discussion 2
R Laptop General Discussion 2
Aoyama Blue Mountain Laptop General Discussion 2
mjmani22 Laptop General Discussion 12
M Laptop General Discussion 3
U Laptop General Discussion 1
S Laptop General Discussion 4
S Laptop General Discussion 3
V Laptop General Discussion 2
A Laptop General Discussion 1
M Laptop General Discussion 1
Lutfij Laptop General Discussion 0
S Laptop General Discussion 2
B Laptop General Discussion 1
E Laptop General Discussion 2
T Laptop General Discussion 1
J Laptop General Discussion 1

ASK THE COMMUNITY