Solved! Laptop doesn't start after keyboard replacement.

Dec 7, 2018
5
0
10
1
Hello guys, I replaced keyboard on my Sony Vaio fit 15 (svf15), assembled it and now it doesn't start at all.
When I press power button it doesn't give any response, no sound, no light nothing. When I plug my ac adapter it doesn't show charging. I wanted ask what could be the possible problems while assembling? Can touching motherboard with bare hands cause problem. I slightly cleared the dust on mb with cloth and fan also.
I've checked all zif cables are rightly connected. Motherboard is seated well.
PLEASE HELP!!!.
Thanks in advance.
 
Dec 7, 2018
5
0
10
1
I found the solution. After trying all. I found a video and as it said I removed the motherboard battery kept it out for 15-20 mins put it back in and then started and it worked.!! This guy came to the rescue : https://youtu.be/8rJl-HMRFOI
Well it says hp laptop but it is common for all laptops/desktops.
 

Saga Lout

Olde English
Moderator
Maybe a cable was accidentally trapped when you closed down the keyboard and trackpad panel.

The first thing to try is to remove that top panel again and use a pencil lead to touch the micro switch that the power button presses. If that fails, try removing the battery and rely on mains only.
 
Dec 7, 2018
5
0
10
1
I found the solution. After trying all. I found a video and as it said I removed the motherboard battery kept it out for 15-20 mins put it back in and then started and it worked.!! This guy came to the rescue : https://youtu.be/8rJl-HMRFOI
Well it says hp laptop but it is common for all laptops/desktops.
 

Saga Lout

Olde English
Moderator
It seems you have to open up again and check it all over. Were the ribbon cables on the old and the new keyboards absolutely identical? If they were and you're sure they fit properly, I'm out of ideas.

What went wrong with the old keyboard?
 
Dec 7, 2018
5
0
10
1
Some of the keys were not working in the last keyboard.
Yes the ribbon cables are identical. I tried fitting ribbon cables perfectly 2 times & that didnt help. I trimmed 1mm of it and then connected it that also didn't work. I tried some more solution (wd-40 spray inside each individual key and all)
But nothing worked so I replaced the old keyboard.
Thanks for support.
 
Thread starter Similar threads Forum Replies Date
Zkneedhelp Laptop Tech Support 2
H Laptop Tech Support 1
Rishabh103 Laptop Tech Support 1
C Laptop Tech Support 1
justin0106 Laptop Tech Support 7
Nohen Laptop Tech Support 4
C Laptop Tech Support 1
A Laptop Tech Support 2
H Laptop Tech Support 1
G Laptop Tech Support 0
JNakov Laptop Tech Support 1
M Laptop Tech Support 2
A Laptop Tech Support 1
L Laptop Tech Support 4
G Laptop Tech Support 1
A Laptop Tech Support 3
S Laptop Tech Support 2
S Laptop Tech Support 2
N Laptop Tech Support 1
G Laptop Tech Support 1

ASK THE COMMUNITY