Laptop won't start. Power-on lights turn on for 3-4 sec, then off. No beeps and no fan.

Balwaj

Estimable
Jul 27, 2014
3
0
4,510
0
Hey.
My little brother dropped his laptop. It landed flat, like when you place it on a table. But now it won't start.
The light on the powerbutton turns on, and so does the light on the front of the laptop. But after 3-4 seconds they turn off again.
After opening the laptop i see that the fan, cooling the cpu, moves very little. Like it's getting power for a tenth of a second.

I have tested a lot of things.
- removed powercord and ac adapter and hold the powerbottun for 60 seconds.
- tested the laptop with all combinations of battery and ac adaptor.
- tested ac adaptor with voltmeter
- reseated ram, graphicscard and harddisk
- tested bios battery (2.9v and that should be fine, right?)

I have not reset bios because I don't know how to do that.

The laptop is an XMG P151HM1. 2½ years old.

Any advice on further testing?



 

Brianaaa

Honorable
Jan 23, 2014
4
0
10,520
1
Np. Found this online, might help idk. Good luck anyway,

After a drop, there are any number of things that can be wrong, but since getting power is the very first step, see if you can Reset your laptop.

To do this, remove the battery and AC Adapter cord, and press and hold the power button for 30 seconds. Then, without replacing the battery try plugging in your AC Adapter to see if you get any love. If that doesn't work, remove the AC adapter, reset the board again, and this time hold the power button down as you plug in the AC Adapter cord. If you still don't get any lights, you could try removing your memory, reset the board, replace the memory, plug in the AC Adapter, and try one more time. If all of this fails, follow the advice of the other guys and get an external hard drive enclosure so you can retrieve your data from the hard drive
 

Karol Wojtyra

Estimable
Feb 11, 2015
1
0
4,510
0
I have the same exact problem with my laptop. Initially it was turning on just fine, by fine i mean it was powering on but it was stuck at blank screen. I then realized that it was a hard drive issue, so I purchased a new HD, i installed it and then I tried turning on my laptop... nothing, I have the same exact problem as you, I tried everything but no cigar. I would greatly appreciate if someone could help us with this problem.