Looking for explanation : HDMI port working with Chromecast but not with laptop

toutentravers

Commendable
Jan 24, 2017
2
0
1,510
0
Hi
I really don't understand what is going on with my TV (LG 60PK250).
It only has 2 HDMI port. One was working fine (PC, Box TV, Chromecast), the other was working but no sound. I decided to get a 3 port HDMI switch to plug in my working HDMI port.
I installed it. Signal from Chromecast worked fine. PC and Box TV signals were not able to get through the switch. I decided I will ship it back.
I plugged back my PC straight to my TV. It's not working anymore. My Box TV shows image, no sound. On both HDMI port. But Chromecast works perfectly on both port. I don't get it.
Does anyone have any idea of what's happening ?
 
I would attach the smallest nozzle to your home vacuum and point it right up at the HDMI ports and suck them up clean.

After that I suspect HDMI cable, stuff in the back of my celebro, too long, weak signal, not v1.4 compliant cable blah-blah.
 

toutentravers

Commendable
Jan 24, 2017
2
0
1,510
0


Hi and thanks for your help.

I tried the home vacuum idea. Unfortunately, it dit not change anything.
HDMI cables are fine, I tried them on another full HD TV. I am still stuck...
 
Thread starter Similar threads Forum Replies Date
M Streaming Video & TVs 1
J Streaming Video & TVs 0
F Streaming Video & TVs 0
R Streaming Video & TVs 0
A Streaming Video & TVs 0
Nostalgia Youtube Streaming Video & TVs 0
yioteh Streaming Video & TVs 2
E Streaming Video & TVs 1
B Streaming Video & TVs 3
G Streaming Video & TVs 1
G Streaming Video & TVs 2
Dman1983 Streaming Video & TVs 2
B Streaming Video & TVs 2
bridgestone-tired Streaming Video & TVs 1
T Streaming Video & TVs 1
M Streaming Video & TVs 0
A Streaming Video & TVs 1
dsr07mm Streaming Video & TVs 3
G Streaming Video & TVs 6
JMcEntegart Streaming Video & TVs 34

ASK THE COMMUNITY