Multiple hard drives not detected in Bios


Jun 24, 2014
I have 3 hard drives from multiple manufacturers.
1 x 160GB Seagate
1 x 160GB Fujitsu
1 x WD Blue 500GB

All are laptop HDD.
The laptop had a dead drive that I tested with seatools and HD Tune pro, it failed both and was completely gone.

The other 3 I tested with the same programs and all are fine. But heres the problem.

I installed the Fujitsu drive and started installing Win7 on it. Everything worked fine. A couple of days later I got back to it and it wouldn't even detect the hard drive. I swopped it with the other 160GB and it got detected but I didn't install windows.

This morning I started it up again to install it, but it too didn't get detected the second 160GB drive at all. So I installed the 500GB drive. then I started to install windows 7 but it failed. There was a problem with the installation media as I tried it on a different pc and failed there too. I copied win7OS over to another flash drive and it worked on the other PC, but when I plugged it into the laptop to install on the 500GB that worked mere moments before, it doesn't detect the hard drive at all. Not even in the BIOS.

I asked a friend who knows more about computers than me and he said I should update the bios. But i'm not sure why that would be the problem. The hard drive worked flawlessly and then the next moment its just gone. Surely the Bios wouldn't do that?
I'm hoping its not the bios as I've got no idea how to update that or even if there is a new update available for it since it isn't too old. About 3-4 years old now.