only green power led on (no POST, no fan)

Irene1972

Estimable
Jan 22, 2016
2
0
4,510
0
When I push the POWER-button from my asus laptop , the only thing that happens is a short noise from the cd drive and further nothing at all. No check of the hard disk, no Fan, NO POST. Just the led of the power is on. The laptop uses AC power , also no battery. Can anybody please help me?
 
Hi,

Please do try these troubleshooting steps that may help in solving the issue.
- Do a hard reset, remove the battery and AC adapter then press and hold the power button for 20 seconds then see if it will boot up normally.
- Next is to test the AC adapter and see if it's supplying enough voltage to power the laptop or better yet try another AC adapter that has the same voltage.
- If there are lights on the laptop indicating it's on connect an external monitor again and see if you'll get a display.
- Also do try and reseat the RAM, remove them all for couple of seconds then put them back in making sure that they are all seated properly into each slot.
- If all these will not work the problem lies in the motherboard of your laptop.
 
Thread starter Similar threads Forum Replies Date
T Laptop Tech Support 1
B Laptop Tech Support 6
K Laptop Tech Support 1
R Laptop Tech Support 1
T Laptop Tech Support 1
S Laptop Tech Support 1
D Laptop Tech Support 6
A Laptop Tech Support 2
M Laptop Tech Support 8
L Laptop Tech Support 1
Q Laptop Tech Support 1
C Laptop Tech Support 1
P Laptop Tech Support 1
L Laptop Tech Support 1
S Laptop Tech Support 4
A Laptop Tech Support 1
G Laptop Tech Support 1
B Laptop Tech Support 1
G Laptop Tech Support 1
G Laptop Tech Support 1

ASK THE COMMUNITY