REALLY STRANGE USB PORT PROBLEMS (tried a lot of stuff to fix it)

Feb 22, 2018
2
0
10
0
Laptop: ASUS K53TA bought in 2013
Mouse: Logitech G502 Proteus Core
Keyboard: Logitech K120 regular business keyboard
Headset: Logitech G933 Artemis Spectrum
P.S. I usually play on a PC I wouldn't buy this stuff if i was gaming on this laptop but It's about 200 km away from me so this will do :)

Ok so It all started when i was playing a steam game Terraria(online with friends). I have only 3 USB ports:mouse,headset USB receiver(wireless) and keyboard(because the laptop is old and the keyboard is very used so it doesn't work very well). You know how some games don't know you disconnected the mouse or keyboard so It wont switch to the keyboard on my laptop(or mouse pad) and when you plug them back in it doesn't work so you have to restart the whole game and reconnect it THEN start the game. So this is one of those games. Usually(on other games)everything is fine after you restart the game, but noooooo. When my headphones charged up i disconnected them and plugged the keyboard in(hell yea)and of course it didn't work. I disconnect everything and plug it back in(the most stupid thing i did in my life don't roast). Guess what? Nothing works. I restart the game. Still nothing works(hell yeaaaa). The G logo on my mouse lights up when i connect it but doesn't work and the logo turns off in about 5 seconds. When I connect something in the USB port you can hear the Win10 sound that goes off when you connect something.The headset works somewhat but nothing is fixed if its still not recognised both in windows and in Logitech Gaming Software. In device manager everything is listed under Other Devices and has a little yellow triangle by It(see picture).
http://i66.tinypic.com/6h6hz7.png

I tried everything that says here:

https://support.microsoft.com/en-us/help/817900/usb-port-may-stop-working-after-you-remove-or-insert-a-usb-device

AND i tried about all that again in clean boot mode. I've been trying stuff for the last 3 days or so. Everything works on other laptops and PCs.

Help would be appreciated,
Thanks In advance,

Sincerely
Vale.
 
Try this...

1. Go to "Control Panel" and then "Device Manager".
2. Expand the "Universal Serial Bus controllers" section.
3. Double-click on the "USB Root Hub device".
4. Now click the "Power Management" tab.
5. Uncheck the "Allow the computer to turn off this device to save power" option.
6. Click the "OK" button.

NOTE: If there is more than one "USB Root Hub device" listed, Then you will have to repeat this steps for each one of them.

7. Restart the computer and all the ports should work now.
 
Feb 22, 2018
2
0
10
0


I've tried that before. This time the ''Power Management'' tab was only on ''USB Root Hub (USB 3.0)'' was the ''Power Management'' tab available. On the rest two there was only the ''Power'' tab. USB ports still aren't working. Thanks for the reply.
 
Thread starter Similar threads Forum Replies Date
TommyInfinity Laptop Tech Support 10
D Laptop Tech Support 1
J Laptop Tech Support 1
Z Laptop Tech Support 1
J Laptop Tech Support 1
Z Laptop Tech Support 4
P Laptop Tech Support 1
W Laptop Tech Support 12
P Laptop Tech Support 1
N Laptop Tech Support 1
V Laptop Tech Support 2
O Laptop Tech Support 2
O Laptop Tech Support 1
M Laptop Tech Support 11
Lumia925 Laptop Tech Support 2
L Laptop Tech Support 5
P Laptop Tech Support 7
B Laptop Tech Support 2
S Laptop Tech Support 3
M Laptop Tech Support 4

ASK THE COMMUNITY