How To Turn Off Subtitles On Samsung Plasma When Using USB Device?

Status
Not open for further replies.

silverslob

Honorable
Aug 31, 2013
4
0
10,520
1
Hello,

I have a Samsung 60" Class 1080p 600Hz Plasma HDTV - PN60F5300AFXZA

When I use the USB on tv to connect a flash device or external hdd the tv's internal media player works fine, my issue is I can't turn off subtitles. If I play any of my movie or tv files on my pc in vlc, pot player or whatever, if the video even has subtitles I have to manually open them(or select language) in order for them to be displayed. But on the tv they just appear and I cannot find a way to turn them through the tv media player.

Is there a way to turn them off through tv, or do I have to somehow run the files through a program on the pc and remove all the subtitles somehow? And if so, what program and how difficult is it?

My cheap $75 bluray player allows me to control subtitles, what is the deal with the Samsung media player in the tv? Am I just not seeing the option? And I must note that turning off subtitles in the basic "CC" tv options does nothing, that is strictly for cable tv subtitles.

Any help is appreciated.
 

silverslob

Honorable
Aug 31, 2013
4
0
10,520
1


Nothing. The remote CC button when pushed displays "function not available", I'm assuming because I don't have cable hooked up. Same goes for CC option in the tv's options menu. The tv's caption function is strictly for cable, satellite or streaming tv I imagine and has nothing to do with the built in Samsung media player.

Update-
I actually went and read the manual I forgot I had, thought I threw it away by accident. It didn't help, nothing on subtitles except the CC button and option in tv settings. But it did tell me there is a Emanual built into my tv, so I hit the Emanual button and boom, more options. After messing around for a few minutes I again found nothing. Frustrated I decided to troubleshoot myself again. In the Emanual it mentioned something about selecting files after you chose a video file to play, but being most my video files are single ones(no .srt ect.) the only option was to play or not to play the video. So I played the video that I had on my small flash drive(Terminator) and played around with the "enter" button which allows one to select rewind, fast forward, pause ect. The last button on the right was yet another option button. There I finally found a option to turn off the subtitles to the video playing.

So if anyone here ever has an issue with turning off subtitles in a video using the usb connect on a Samsung tv all you need to do is hit "enter"(center button surrounds by up, down, left, right arrows) on remote and right arrow to the last button on the right which is yet another settings button and enter there, very first option is to turn off subtitles.

Ugh! Finally. Thanks for caring popatim! Your reply got me motivated.



 

silverslob

Honorable
Aug 31, 2013
4
0
10,520
1


Nothing. The remote CC button when pushed displays "function not available", I'm assuming because I don't have cable hooked up. Same goes for CC option in the tv's options menu. The tv's caption function is strictly for cable, satellite or streaming tv I imagine and has nothing to do with the built in Samsung media player.

Update-
I actually went and read the manual I forgot I had, thought I threw it away by accident. It didn't help, nothing on subtitles except the CC button and option in tv settings. But it did tell me there is a Emanual built into my tv, so I hit the Emanual button and boom, more options. After messing around for a few minutes I again found nothing. Frustrated I decided to troubleshoot myself again. In the Emanual it mentioned something about selecting files after you chose a video file to play, but being most my video files are single ones(no .srt ect.) the only option was to play or not to play the video. So I played the video that I had on my small flash drive(Terminator) and played around with the "enter" button which allows one to select rewind, fast forward, pause ect. The last button on the right was yet another option button. There I finally found a option to turn off the subtitles to the video playing.

So if anyone here ever has an issue with turning off subtitles in a video using the usb connect on a Samsung tv all you need to do is hit "enter"(center button surrounds by up, down, left, right arrows) on remote and right arrow to the last button on the right which is yet another settings button and enter there, very first option is to turn off subtitles.

Ugh! Finally. Thanks for caring popatim! Your reply got me motivated.



 

andjj

Honorable
Dec 12, 2013
1
0
10,510
0
I have the same issue with my Samsung UE46ES8000 smart TV. I play all my films through USB devices and with some files in some formats (.mkv, .avi, .MP4) I get constant subtitles, very annoying and very distracting. The video files I have trouble with are single files, no .srt files with them which I could remove. My TV subtitle settings are set to OFF, on my remote there is a button AD/SUBT. which when pressed brings up a 'not available' message but changes nothing.

I have tried your solution above silverslob, but unfortunately it does not work for me. I have an enter button with directional keys, but in a video all mine does is incrementally advance or reverse the video, I don't get any extra options buttons as you indicated.

Does anyone have a solution for this issue please?



Edit: Ok thats annoying. I've been looking for a solution for this for about 6 months. I've mailed Samsung support and posted on sites like this... after thinking about what silverslob said, I knew there must be another tier of options somewhere, so I played a video and hit every button on my remote, no matter how unlikely it sounded. I found an extra option panel opens when playing video under the 'Tools' button. Subtitle was set to 'English' on there. Very annoying and counter intuitive. Thanks for the indirect help Silver.
 

nc4207

Estimable
Apr 4, 2014
1
0
4,510
0
Hello, all it seems you have to do is - while the video is playing - press the tools button. Select the setting option (the cog icon). The subtitle option should the the top option.
 

vampyiere6

Honorable
Mar 7, 2013
33
0
10,590
1
most likley depending if you have downloaded the movie or have just ripped it there should be a skv file if i remember the name right.

put the usb in a computer and delete the skv (text file) it should be named the same as the movie itself after deleting it there will be no subbtitles unless they are hard coded into the movie then its way harder
 

KosicMil

Estimable
Oct 30, 2015
1
0
4,510
0


Ahhhh thanks so much! I was just having the same problem and had no clue how to fix it. You're a lifesaver!
 
Status
Not open for further replies.
Thread starter Similar threads Forum Replies Date
T Streaming Video & TVs 1
E Streaming Video & TVs 1
R Streaming Video & TVs 0
R Streaming Video & TVs 1
C Streaming Video & TVs 1
R Streaming Video & TVs 0
R Streaming Video & TVs 0
M Streaming Video & TVs 1
F Streaming Video & TVs 7
C Streaming Video & TVs 2
P Streaming Video & TVs 1
A Streaming Video & TVs 1
C Streaming Video & TVs 2
O Streaming Video & TVs 5
R Streaming Video & TVs 2
E Streaming Video & TVs 1
C Streaming Video & TVs 1
V Streaming Video & TVs 1
M Streaming Video & TVs 9
B Streaming Video & TVs 3

ASK THE COMMUNITY

TRENDING THREADS