Laptop, no post

Handley2000

Commendable
Apr 18, 2016
1
0
1,510
0
Asus laptop S56CM/K56CM, after restarting no longer post, no bios splash, no backlighting on screen, fans not spinning, power led is on. I have tried clearing the charge holding the power button, booting with and without ram as well as different ram, reseating cmos battery. Any ideas or suggestions before I order a new motherboard? Thanks.
 
Hi,

Here are some troubleshooting steps that you may want to try first before ordering a new motherboard.
- Start by doing a hard reboot, remove the battery and unplug the AC adapter then press and hold the power button for 20 seconds then try booting it up again.
- If this will not work, do test the AC adapter if it's working properly. Remove the battery and power the laptop with just the AC adapter connected and see if it will boot up or not. do also try a different AC adapter that has the same voltage and see if it will work or not.
- Proceed with reseating the RAM's if trying a different AC adapter will not work, remove them all for couple of seconds then put them back in making sure everything is seated properly.
- If it will still not work, connect an external monitor and see if you'll get any display from it. If there's a display on the external monitor that could mean that the problem is the built in display.
- But if there's still no display on the external monitor that means the problem lies in the motherboard.
 
Thread starter Similar threads Forum Replies Date
AsusExcitement65 Laptop Tech Support 2
C Laptop Tech Support 0
SteaJdj Laptop Tech Support 0
C Laptop Tech Support 1
F Laptop Tech Support 3
A Laptop Tech Support 6
F Laptop Tech Support 2
W Laptop Tech Support 1
ChadPudding Laptop Tech Support 1
Peudekai Laptop Tech Support 3
Anderdid Laptop Tech Support 13
jmechav Laptop Tech Support 0
amphx Laptop Tech Support 3
Stachu213_ Laptop Tech Support 0
VJK Laptop Tech Support 1
SSGB8 Laptop Tech Support 2
jankeza Laptop Tech Support 9
S Laptop Tech Support 0
Darelll Laptop Tech Support 1
S Laptop Tech Support 0

ASK THE COMMUNITY