WD my passport ultra, was working fine, suddenly disappeared

Mohab_

Estimable
Dec 8, 2015
1
0
4,510
0
Hi, I have a WD my passport ultra, that has been working fine, suddenly in the middle of a file transfer it disappeared! and the blinking stopped, now the light is stable and on (all the time). when I open device manager, I find it and it says: device working properly. I changed the usb port, I changed the usb cable, and tried it in other laptops, and same behavior exactly happens. when I disconnect and re connect the windows sounds happen, but still the device is not viewable regularly on my computer like it used to be! i kept it connected for over an hour, and it started blinking but slowly, and im still leaving it connected, but I dunno what to do.
Please help
 

D_Know_WD

Estimable
Jul 30, 2014
309
0
5,910
124
Hi there Mohab_,

Sorry that you are facing some issues with your WD drive. :(
Is the drive under warranty? Do you have some important data stored on it?

One thing you need to do is to go to Disk Management and see whether and how the drive appears over there.
In case it does, but has damaged partitions and/or file system, you may need to use some data/partition recovery tool in order to retrieve the data.
After that, you need to just test it with WD's Data Lifeguard Diagnostic tool: http://products.wdc.com/support/kb.ashx?id=ztyODG

In case the drive does not appear under Disk Management, and you've already tried attaching it with a different cable to a different system, then I guess there is something wrong with the enclosure or the drive itself.
In that case you can:
- Just RMA the drive in case it is under warranty. You can contact WD's support on that: http://products.wdc.com/support/kb.ashx?id=vQKw9B
- Contact a data recovery company in case the data stored on the drive is really important. You can check WD's Data Recovery Partners out: http://products.wdc.com/support/kb.ashx?id=gG71aE

Let me know how this goes,
D_Know_WD :)
 

Similar threads