thedarkboy77

Commendable
Jun 27, 2016
1
0
1,510
0
My asus laptop stopped functioning properly after I used a new charger. The charger's output is 19.5 volt and my laptop takes 19 volt. In the shop, my laptop was functioning properly with the new charger. I brought it home and left it charge all night since the battery was completely depleted of charge. The next morning, the charging light was blinking and when I turn it on, it shuts down. I tried with another charger with no results. I noticed that my laptop no longer indicate the charging light when connected. I removed all components with only the charger, but it still won't turn on. I jump started my battery and connected it to the motherboard and the charging light lights up when connected to a charger, but the light fades away afterward. I also noticed that my laptop no longer charges my battery, even by jump starting it. The output volt for battery port on the motherboard is 1.05 volts. The charging port on my motherboard is 19.5 volt. My laptop doesn't turn on even with the charger alone. What problems could it have?
 
Thread starter Similar threads Forum Replies Date
Anyounmous Laptop Tech Support 0
Ryun1975 Laptop Tech Support 2
C Laptop Tech Support 5
B Laptop Tech Support 6
M Laptop Tech Support 1
Prikster Laptop Tech Support 0
DariusEldritch Laptop Tech Support 0
K Laptop Tech Support 0
X Laptop Tech Support 0
LucieVdw Laptop Tech Support 2
K Laptop Tech Support 2
YoussefChi Laptop Tech Support 4
ElPerroMalo Laptop Tech Support 5
A Laptop Tech Support 1
S Laptop Tech Support 1
R Laptop Tech Support 2
L Laptop Tech Support 1
G Laptop Tech Support 4
M Laptop Tech Support 1
J Laptop Tech Support 2

ASK THE COMMUNITY